Bug #87073 InnoDB: Assertion failure in thread 140234383988480 in file btr0sea.cc line 579
Submitted: 14 Jul 2017 15:12 Modified: 14 Jul 2017 16:46
Reporter: Enrico Cairo Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S3 (Non-critical)
Version:5.6.11 OS:CentOS (CentOS release 6.4 (Final))
Assigned to: CPU Architecture:Any

[14 Jul 2017 15:12] Enrico Cairo
Description:
2017-07-13 21:53:21 7f8adca49700  InnoDB: Assertion failure in thread 140234383988480 in file btr0sea.cc line 579
InnoDB: Failing assertion: index == cursor->index
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
19:53:21 UTC - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed,
something is definitely wrong and this may fail.

How to repeat:
firt time it happens
[14 Jul 2017 15:15] Enrico Cairo
error log

Attachment: safe_fioredb02.log (application/octet-stream, text), 2.34 MiB.

[14 Jul 2017 16:46] Miguel Solorzano
Thank you for taking the time to report a problem.  Unfortunately you
are not using a current version of the product you reported a problem
with -- the problem might already be fixed. Please download
a new version from http://www.mysql.com/downloads/. Current version is 5.6.36.

Also, there is no test case provided in the bug report and hence there
is nothing we can verify here.  If you are able to reproduce the bug
with one of the latest versions, please attach the exact reproducible
test case and change the version on this bug report to the version you
tested and change the status back to "Open".  Again, thank you for your
continued support of MySQL.