Bug #86772 There is no local IP address matching the one configured for the local node
Submitted: 21 Jun 2017 8:30 Modified: 15 Dec 2017 16:19
Reporter: Jackin Chan Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Group Replication Severity:S3 (Non-critical)
Version:5.7.18 OS:CentOS (CentOS 6.6 x86_64)
Assigned to: CPU Architecture:Any

[21 Jun 2017 8:30] Jackin Chan
Description:
Execute "start group_replication" fail and error log show : 

'[GCS] There is no local IP address matching the one configured for the local node (10.202.44.222:24901).'

How to repeat:
we bind many vip in one machine, it seems that MGR can not recognize all of the vips we bind :

ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
2: eth0: <BROADCAST,MULTICAST,SLAVE,UP,LOWER_UP> mtu 1500 qdisc mq master bond0 state UP qlen 1000
    link/ether d4:ae:52:78:99:56 brd ff:ff:ff:ff:ff:ff
3: eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN qlen 1000
    link/ether d4:ae:52:78:99:58 brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.6/24 brd 192.168.0.255 scope global eth1
4: eth2: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether d4:ae:52:78:99:5a brd ff:ff:ff:ff:ff:ff
5: eth3: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
    link/ether d4:ae:52:78:99:5c brd ff:ff:ff:ff:ff:ff
6: bond0: <BROADCAST,MULTICAST,MASTER,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP 
    link/ether d4:ae:52:78:99:56 brd ff:ff:ff:ff:ff:ff
    inet 10.202.44.200/24 brd 10.202.44.255 scope global bond0
    inet 10.202.44.56/24 brd 10.202.44.255 scope global secondary bond0:100
    inet 10.202.44.35/24 brd 10.202.44.255 scope global secondary bond0:101
    inet 10.202.44.81/24 brd 10.202.44.255 scope global secondary bond0:102
    inet 10.202.44.36/24 brd 10.202.44.255 scope global secondary bond0:103
    inet 10.202.44.99/24 brd 10.202.44.255 scope global secondary bond0:104
    inet 10.202.44.177/24 brd 10.202.44.255 scope global secondary bond0:105
    inet 10.202.44.194/24 brd 10.202.44.255 scope global secondary bond0:106
    inet 10.202.44.236/24 brd 10.202.44.255 scope global secondary bond0:108
    inet 10.202.44.197/24 brd 10.202.44.255 scope global secondary bond0:110
    inet 10.202.44.167/24 brd 10.202.44.255 scope global secondary bond0:113
    inet 10.202.44.40/24 brd 10.202.44.255 scope global secondary bond0:18
    inet 10.202.44.39/24 brd 10.202.44.255 scope global secondary bond0:19
    inet 10.202.44.38/24 brd 10.202.44.255 scope global secondary bond0:20
    inet 10.202.44.2/24 brd 10.202.44.255 scope global secondary bond0:21
    inet 10.202.44.3/24 brd 10.202.44.255 scope global secondary bond0:22
    inet 10.202.44.4/24 brd 10.202.44.255 scope global secondary bond0:23
    inet 10.202.44.204/24 brd 10.202.44.255 scope global secondary bond0:35
    inet 10.202.44.32/24 brd 10.202.44.255 scope global secondary bond0:40
    inet 10.202.44.34/24 brd 10.202.44.255 scope global secondary bond0:41
    inet 10.202.44.30/24 brd 10.202.44.255 scope global secondary bond0:42
    inet 10.202.44.31/24 brd 10.202.44.255 scope global secondary bond0:43
    inet 10.202.44.47/24 brd 10.202.44.255 scope global secondary bond0:45
    inet 10.202.44.50/24 brd 10.202.44.255 scope global secondary bond0:47
    inet 10.202.44.51/24 brd 10.202.44.255 scope global secondary bond0:48
    inet 10.202.44.52/24 brd 10.202.44.255 scope global secondary bond0:52
    inet 10.202.44.53/24 brd 10.202.44.255 scope global secondary bond0:53
    inet 10.202.44.54/24 brd 10.202.44.255 scope global secondary bond0:54
    inet 10.202.44.66/24 brd 10.202.44.255 scope global secondary bond0:55
    inet 10.202.44.49/24 brd 10.202.44.255 scope global secondary bond0:56
    inet 10.202.44.25/24 brd 10.202.44.255 scope global secondary bond0:58
    inet 10.202.44.28/24 brd 10.202.44.255 scope global secondary bond0:59
    inet 10.202.44.57/24 brd 10.202.44.255 scope global secondary bond0:60
    inet 10.202.44.55/24 brd 10.202.44.255 scope global secondary bond0:61
    inet 10.202.44.64/24 brd 10.202.44.255 scope global secondary bond0:62
    inet 10.202.44.67/24 brd 10.202.44.255 scope global secondary bond0:63
    inet 10.202.44.68/24 brd 10.202.44.255 scope global secondary bond0:64
    inet 10.202.44.69/24 brd 10.202.44.255 scope global secondary bond0:65
    inet 10.202.44.10/24 brd 10.202.44.255 scope global secondary bond0:66
    inet 10.202.44.12/24 brd 10.202.44.255 scope global secondary bond0:67
    inet 10.202.44.201/24 brd 10.202.44.255 scope global secondary bond0:68
    inet 10.202.44.24/24 brd 10.202.44.255 scope global secondary bond0:69
    inet 10.202.44.29/24 brd 10.202.44.255 scope global secondary bond0:70
    inet 10.202.44.33/24 brd 10.202.44.255 scope global secondary bond0:71
    inet 10.202.44.37/24 brd 10.202.44.255 scope global secondary bond0:72
    inet 10.202.44.41/24 brd 10.202.44.255 scope global secondary bond0:73
    inet 10.202.44.42/24 brd 10.202.44.255 scope global secondary bond0:74
    inet 10.202.44.43/24 brd 10.202.44.255 scope global secondary bond0:75
    inet 10.202.44.44/24 brd 10.202.44.255 scope global secondary bond0:76
    inet 10.202.44.45/24 brd 10.202.44.255 scope global secondary bond0:77
    inet 10.202.44.46/24 brd 10.202.44.255 scope global secondary bond0:78
    inet 10.202.44.48/24 brd 10.202.44.255 scope global secondary bond0:79
    inet 10.202.44.5/24 brd 10.202.44.255 scope global secondary bond0:80
    inet 10.202.44.58/24 brd 10.202.44.255 scope global secondary bond0:81
    inet 10.202.44.6/24 brd 10.202.44.255 scope global secondary bond0:82
    inet 10.202.44.60/24 brd 10.202.44.255 scope global secondary bond0:83
    inet 10.202.44.61/24 brd 10.202.44.255 scope global secondary bond0:84
    inet 10.202.44.62/24 brd 10.202.44.255 scope global secondary bond0:85
    inet 10.202.44.7/24 brd 10.202.44.255 scope global secondary bond0:86
    inet 10.202.44.70/24 brd 10.202.44.255 scope global secondary bond0:87
    inet 10.202.44.8/24 brd 10.202.44.255 scope global secondary bond0:88
    inet 10.202.44.11/24 brd 10.202.44.255 scope global secondary bond0:90
    inet 10.202.44.1/24 brd 10.202.44.255 scope global secondary bond0:91
    inet 10.202.44.13/24 brd 10.202.44.255 scope global secondary bond0:92
    inet 10.202.44.65/24 brd 10.202.44.255 scope global secondary bond0:93
    inet 10.202.44.59/24 brd 10.202.44.255 scope global secondary bond0:94
    inet 10.202.44.21/24 brd 10.202.44.255 scope global secondary bond0:95
    inet 10.202.44.80/24 brd 10.202.44.255 scope global secondary bond0:96
    inet 10.202.44.26/24 brd 10.202.44.255 scope global secondary bond0:98
    inet 10.202.44.27/24 brd 10.202.44.255 scope global secondary bond0:99
    inet 10.202.44.230/24 brd 10.202.44.255 scope global secondary bond0:114
    inet 10.202.44.233/24 brd 10.202.44.255 scope global secondary bond0:115
    inet 10.202.44.222/24 brd 10.202.44.255 scope global secondary bond0:116

config my.cnf with the last vip 10.202.44.222, and executed :

mysql> set global group_replication_bootstrap_group = ON;
Query OK, 0 rows affected (0.00 sec)

mysql> start group_replication;
ERROR 3096 (HY000): The START GROUP_REPLICATION command failed as there was an error when initializing the group communication layer.

error log :

2017-06-21T16:27:21.082775+08:00 4 [Note] Plugin group_replication reported: 'Group communication SSL configuration: group_replication_ssl_mode: "DISABLED"'
2017-06-21T16:27:21.083428+08:00 4 [Note] Plugin group_replication reported: '[GCS] Added automatically IP ranges 10.202.44.177/24,10.202.44.194/24,10.202.44.197/24,10.202.44.200/24,10.202.44.236/24,10.202.44.35/24,10.202.44.36/24,10.202.44.56/24,10.202.44.81/24,10.202.44.99/24,127.0.0.1/8,192.168.0.6/24 to the whitelist'
2017-06-21T16:27:21.083714+08:00 4 [ERROR] Plugin group_replication reported: '[GCS] There is no local IP address matching the one configured for the local node (10.202.44.222:24901).'
2017-06-21T16:27:21.083745+08:00 4 [ERROR] Plugin group_replication reported: 'Unable to initialize the group communication engine'
2017-06-21T16:27:21.083760+08:00 4 [ERROR] Plugin group_replication reported: 'Error on group communication engine initialization'
2017-06-21T16:27:21.083811+08:00 4 [Note] Plugin group_replication reported: 'Requesting to leave the group despite of not being a member'
2017-06-21T16:27:21.083827+08:00 4 [ERROR] Plugin group_replication reported: 'Error calling group communication interfaces while trying to leave the group'
[21 Jun 2017 8:31] Jackin Chan
Group Replication config :

transaction_write_set_extraction=XXHASH64
loose-group_replication_single_primary_mode=true
loose-group_replication_enforce_update_everywhere_checks=false
loose-group_replication_group_name="aaaaaaaa-aaaa-aaaa-aaaa-aaaaaaaaaaaa"
loose-group_replication_start_on_boot=off
loose-group_replication_bootstrap_group=off
loose-group_replication_local_address= "10.202.44.222:24901"
loose-group_replication_group_seeds= "10.202.44.222:24901"

super_read_only=1
report_host=10.202.44.222
[21 Jun 2017 18:49] Bogdan Kecman
Hi,

Thanks for the submission, bug is verified as described.

Best regards
Bogdan Kecman
[15 Dec 2017 16:19] David Moss
Posted by developer:
 
Thank you for your feedback, this has been fixed in upcoming versions and the following was added to the 5.7.21  / 8.0.4 changelog:
Regardless of the number of virtual IPs configured on a machine, Group Replication could access only the first 12 addresses.
[8 Jan 2018 6:50] Umesh Shastry
Bug #89123 marked as duplicate of this one
[3 Sep 2018 3:32] Ronak Zaveri
Having the same error in  Version: '5.7.22-enterprise-commercial-advanced-log

[ERROR] Plugin group_replication reported: '[GCS] There is no local IP address matching the one configured for the local node (X.X.X.X:24901)

Is there any solution.
[3 Sep 2018 7:36] Umesh Shastry
Hello Ronak Zaveri,

Please be informed that this issue has been fixed in 5.7.23 post Bug #89123 fix. Change log details from Bug #89123

Posted by developer:
 
Thank you for your feedback, this has been fixed in upcoming versions and the following was added to the 5.7.23 changelog:
This bug was fixed by backporting the fix for bug#27376511.

Thanks,
Umesh
[4 Sep 2018 23:11] Ronak Zaveri
Thanks Umesh Shastry,

I am configuring on Oracle Cloud in which latest version is MySQL Server Release 5.7.22.
Now, I am looking for solution to fix it .!

Regards 
Ronak Zaveri