Bug #86569 InnoDB: Error: semaphore wait has lasted > 600 seconds
Submitted: 3 Jun 2017 0:56 Modified: 3 Jun 2017 14:25
Reporter: Yage Gu Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:5.6.30 OS:CentOS (6.6)
Assigned to: CPU Architecture:Any
Tags: InnoDB: Error: semaphore wait has lasted > 600 seconds

[3 Jun 2017 0:56] Yage Gu
Description:
--------------
ROW OPERATIONS
--------------
0 queries inside InnoDB, 0 queries in queue
11 read views open inside InnoDB
Main thread process no. 25403, id 139861988017920, state: enforcing dict cache limit
Number of rows inserted 2874216, updated 2220456, deleted 95214, read 135178811996
4.00 inserts/s, 2.00 updates/s, 0.00 deletes/s, 1878.47 reads/s
----------------------------
END OF INNODB MONITOR OUTPUT
============================
InnoDB: ###### Diagnostic info printed to the standard error stream
InnoDB: Error: semaphore wait has lasted > 600 seconds
InnoDB: We intentionally crash the server, because it appears to be hung.
2017-06-03 07:40:17 7f34295d2700  InnoDB: Assertion failure in thread 139862008997632 in file srv0srv.cc line 1756
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
23:40:17 UTC - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help
diagnose the problem, but since we have already crashed, 
something is definitely wrong and this may fail.

How to repeat:
This error has been seven to eight times, recently more and more frequent
[3 Jun 2017 1:00] Yage Gu
Part of the error log, because other contains customer information

Attachment: mysqlderr.log (application/octet-stream, text), 109.22 KiB.

[3 Jun 2017 14:25] Miguel Solorzano
Thank you for taking the time to report a problem.  Unfortunately you
are not using a current version of the product you reported a problem
with -- the problem might already be fixed. Please download
a new version from http://www.mysql.com/downloads/.

Also, there is no test case provided in the bug report and hence there
is nothing we can verify here.  If you are able to reproduce the bug
with one of the latest versions, please attach the exact reproducible
test case and change the version on this bug report to the version you
tested and change the status back to "Open".  Again, thank you for your
continued support of MySQL.