Bug #86480 Mysql Sever 5.7.13 crashes : InnoDB: Assertion failure in thread 4692 in file fi
Submitted: 26 May 2017 19:31 Modified: 26 May 2017 19:48
Reporter: MOE WAHIDI Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:5.7.13 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[26 May 2017 19:31] MOE WAHIDI
Description:
We upgraded our mySQL database server from version 5.0.67 to 5.7.13. The windows box hosting the mysql server is still the same machine and nothing changed. we have applications that connects to the MySQl database and when we were using version 5.0.67 we never experienced any crash
We upgraded to version 5.7.13 2 weeks ago and the upgrade was successful. Also we did mysqlcheck on all tables and all was good. The Mysql server version 5.7.13 crashed twice since the upgrade . See below error. 
The windows server is a 6 GB system and has lot of available memory.

Below is error from MySQL log:

2017-05-26T10:39:04.618746Z 0 [ERROR] InnoDB: The error means that the I/O operation has been aborted because of either a thread exit or an application request. Retry attempt is made.
2017-05-26 03:39:04 0x1254  InnoDB: Assertion failure in thread 4692 in file fil0fil.cc line 5817
InnoDB: Failing assertion: err == DB_SUCCESS
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.7/en/forcing-innodb-recovery.html
InnoDB: about forcing recovery.
10:39:04 UTC - mysqld got exception 0x80000003 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
Attempting to collect some information that could help diagnose the problem.
As this is a crash and something is definitely wrong, the information
collection process might fail.

key_buffer_size=8388608
read_buffer_size=65536
max_used_connections=19
max_threads=151
thread_count=7
connection_count=7
It is possible that mysqld could use up to 
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 58346 K  bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
13fd7ab42    mysqld.exe!my_errno()
14011ef09    mysqld.exe!my_wildcmp_mb()
14011de00    mysqld.exe!my_wildcmp_mb()
13fe7bd88    mysqld.exe!?reserve@?$vector@EV?$allocator@E@std@@@std@@QEAAX_K@Z()
13fea2b5a    mysqld.exe!?reserve@?$vector@EV?$allocator@E@std@@@std@@QEAAX_K@Z()
13fe46574    mysqld.exe!?reserve@?$vector@EV?$allocator@E@std@@@std@@QEAAX_K@Z()
770e59cd    kernel32.dll!BaseThreadInitThunk()
7721a561    ntdll.dll!RtlUserThreadStart()

How to repeat:
over time and random. We do not know what cuase it  Server crashes after 7 to 10 days

Suggested fix:
NA
When server crash we recover by just starting the server again
[26 May 2017 19:48] Miguel Solorzano
Thank you for taking the time to report a problem.  Unfortunately you
are not using a current version of the product you reported a problem
with -- the problem might already be fixed. Please download
a new version from http://www.mysql.com/downloads/ the current version is 5.7.18.

Also, there is no test case provided in the bug report and hence there
is nothing we can verify here.  If you are able to reproduce the bug
with one of the latest versions, please attach the exact reproducible
test case and change the version on this bug report to the version you
tested and change the status back to "Open".