Bug #8634 Configuration wizzard aborted trying to start service
Submitted: 20 Feb 2005 17:08 Modified: 22 Mar 2005 12:56
Reporter: Nicholas Ourusoff Email Updates:
Status: Won't fix Impact on me:
None 
Category:MySQL Server: Installing Severity:S1 (Critical)
Version:mySQL Server 4.1 OS:Microsoft Windows (XP)
Assigned to: Michael G. Zinner CPU Architecture:Any

[20 Feb 2005 17:08] Nicholas Ourusoff
Description:
The Configuration Wizzard exeuctes the first two steps, but cannot install and start the service.
I tried to execute the mysql --console script
It aborted with the message:
".\ib_logfile0 is a different size 10485760 bytes than specified in .cnf file 0 5242880 bytes
Can't init databases
Aborting"

How to repeat:
Re-install from the download and run the Installation Wizzard and Configuration Wizzard again.
[22 Mar 2005 12:32] [ name withheld ]
how you fix this bug?? - i tried re-installing like 4 times
[22 Mar 2005 12:56] Michael G. Zinner
The problem is, if you are upgrading from and older version (below 4.1.7) the logfile settings cannot be retrieved.

You have to adjust this manually.

1) Open the file C:\Program Files\MySQL\MySQL Server 4.1\my.ini
2) Scroll down to the #*** INNODB Specific options ***
3) Correct the innodb_log_file_size=10M to innodb_log_file_size=5M or whatever your original settings were
4) Make sure you do not have a config file in C:\my.cnf and C:\Windows\my.ini
5) Re-run the Config Wizard or start the server manually by executing NET START mysql (or what your service name is) from the command line

From now on this will work as expected when you re-run the Config Wizard or you upgrade to a new 4.1 version.