Bug #862 is it possible to hold idle connections while using a few process to work?
Submitted: 17 Jul 2003 1:26 Modified: 24 Jul 2003 5:33
Reporter: xuefer tinys Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S4 (Feature request)
Version:4.0.x OS:Linux (linux)
Assigned to: CPU Architecture:Any
Triage: D5 (Feature request)

[17 Jul 2003 1:26] xuefer tinys
Description:
php told us we should use mysql_pconnect
then we get into troubble now
we have many httpd process each connected to mysql server
but most of them is idling
e.g.: serving gif/jpg/swf static files
but each mysql process takes too much memory resource (%3 mem for each)

How to repeat:
http, serving "many dynamic(php,perl)" but plus "much more static files"

Suggested fix:
i don't know if it's possible, but i'd hope that mysql can hold those idle connections, while usiong only a few process to do the queries for running connection
and we'll have 2 new value to config: max connection, max process

many thanks
[24 Jul 2003 5:33] Indrek Siitan
This is not a bug report.

You should use two Apache servers - one for dynamic content, and the other for serving static 
files.