Bug #86119 SERVER_PS_OUT_PARAMS not set with prepared call statement
Submitted: 27 Apr 2017 19:27 Modified: 11 May 2017 13:31
Reporter: John Dow Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: C API (client library) Severity:S3 (Non-critical)
Version:5.7.18 OS:Debian
Assigned to: CPU Architecture:Any

[27 Apr 2017 19:27] John Dow
Description:
SERVER_PS_OUT_PARAMS is not set in server_status when using a prepared call statement with OUT/INOUT parameters, like in the example from 

https://dev.mysql.com/doc/refman/5.7/en/c-api-prepared-call-statements.html

Linked with:
-L/usr/lib/x86_64-linux-gnu -lmysqlclient -lpthread -lz -lm -lrt -latomic -ldl

How to repeat:
compile and run the sample from 
https://dev.mysql.com/doc/refman/5.7/en/c-api-prepared-call-statements.html

Output is:

Number of columns in result: 3
Data: this result set is produced by the procedure
 val[0] = 10; val[1] = NULL; val[2] = 30;
Number of columns in result: 3
Data: this result set is produced by the procedure
 val[0] = 100; val[1] = 200; val[2] = 300;
Number of columns in result: 2
Data: this result set is produced by the procedure <--- Should 'contains OUT/INOUT parameters'
 val[0] = 200; val[1] = 300;
End of procedure output
[11 May 2017 8:50] Chiranjeevi Battula
Hello John Dow,

Thank you for the bug report.
This is most likely duplicate of Bug #79662, please see Bug #79662.

Thanks,
Chiranjeevi.
[11 May 2017 13:31] John Dow
Hello Chiranjeevi,

I "do not have access to bug #79662."