Bug #86041 Installer MSI leaves behind 8 invalid firewall rules & 1 missing MUI reference
Submitted: 21 Apr 2017 21:32 Modified: 25 Apr 2017 8:47
Reporter: J Scavok Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL for Windows: Installer Severity:S3 (Non-critical)
Version:5.7.18.1 OS:Microsoft Windows (Windows 7 Pro SP1 64-bit)
Assigned to: CPU Architecture:Any
Tags: installer, Invalid firewall rule, missing mui reference, Windows Registry

[21 Apr 2017 21:32] J Scavok
Description:
Fresh install using mysql-installer-community-5.7.18.1.msi leaves behind eight invalid firewall rules and one missing MUI reference in the Windows Registry.

How to repeat:
1. Run Piriform CCleaner (or equivalent) to resolve all Windows Registry issues beforehand.

2. Run mysql-installer-community-5.7.18.1.msi

During the guided, step-by-step process, there is a step for TCP/IP and firewall, in which both check boxes (one for TCP/IP and one for opening the firewall to allow port 3306) are checked by default (i.e., enabled).

I unchecked the box next to opening the firewall to allow port 3306.

The installation successfully completed.

Afterward, in the \ProgramData\MySQL\MySQL Installer for Windows\Logs .log file, there was this relevant entry for the choice I made in this step:

mysql-installer Information: 10 : Attempting to create firewall rule with command: netsh.exe  firewall delete portopening protocol=TCP port=3306 profile=ALL

3. When I ran Piriform CCleaner after the installation, there were eight invalid firewall rules and one missing MUI reference present in the Windows Registry.

Suggested fix:
The installer must not have any Windows Registry-related issues upon completion.
[21 Apr 2017 21:34] J Scavok
Leftover Windows Registry Issues from Installer

Attachment: installer-windows-registery-issues.jpg (image/jpeg, text), 125.87 KiB.

[24 Apr 2017 7:52] Umesh Shastry
Hello J Scavok,

Thank you for the report.
I tried 5.7.18 installation using installer and following your steps but I'm not seeing reported issues. Moreover, looking at '5.7.17' entries in your screenshot I wonder whether this is caused by 5.7.18 installer or previous one. Could you please confirm the same?

Thanks,
Umesh
[24 Apr 2017 19:53] J Scavok
You've made a keen observation--and I admit I missed it myself.

It is true 5.7.17 _was_ present at one time. Its source was mysql-5.7.17-winx64.zip, which as you know is _not_ the same as a MSI.

5.7.17 was _not_ installed as a Windows Service. And the only Windows setting I remember changing was the path environment variable. 

Now then: did I change the Windows Firewall also? I don't remember doing so. But if it was necessary in order to run mysqld 5.7.17, then I must have done so. 

After I removed 5.7.17 by deleting its directory, I ran Piriform CCleaner to resolve any Windows Registry issues. So it is strange that these presumably leftover Windows Registry issues from 5.7.17 would suddenly appear _after_ installing 5.7.18.
[25 Apr 2017 8:47] Umesh Shastry
Thank you for confirming.
Considering 5.7.17 was not installed through any *MSI installer, I assume earlier manual attempt attempt while setting might have left any footprints. I'm not sure installer would attempt to change anything which was set manually, so lets assume that it was a corner case and now it is not possible to reproduce.   Thank you for your interest in MySQL.

Thanks,
Umesh