Bug #85725 mysql group replication
Submitted: 31 Mar 2017 6:17 Modified: 7 Apr 2017 23:00
Reporter: nothing radong Email Updates:
Status: Not a Bug Impact on me:
None 
Category:Tests: Group Replication Severity:S3 (Non-critical)
Version:5.7.17 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[31 Mar 2017 6:17] nothing radong
Description:
I want to use group replication,when I config it according to to mysql official document,I have this error:

 2017-03-31T05:10:18.810000Z 3 [Note] Plugin group_replication reported: 'Group communication SSL configuration: group_replication_ssl_mode: "DISABLED"'
2017-03-31T05:10:18.810000Z 3 [Note] Plugin group_replication reported: 'The Winsock 2.2 dll was found okay'
2017-03-31T05:10:18.810000Z 3 [Note] Plugin group_replication reported: '[GCS] Added automatically IP ranges 127.0.0.1/8,192.168.10.206/24 to the whitelist'
2017-03-31T05:10:18.810000Z 3 [Note] Plugin group_replication reported: '[GCS] SSL was not enabled'
2017-03-31T05:10:18.810000Z 3 [Note] Plugin group_replication reported: 'Initialized group communication with configuration: group_replication_group_name: "aaaaaaaa-aaaa-aaaa-aaaa-aaaaaaaaaaaa"; group_replication_local_address: "192.168.10.206:24901"; group_replication_group_seeds: "192.168.10.150:24901,192.168.10.206:24901"; group_replication_bootstrap_group: false; group_replication_poll_spin_loops: 0; group_replication_compression_threshold: 1000000; group_replication_ip_whitelist: "AUTOMATIC"'
2017-03-31T05:10:18.810000Z 4 [Note] 'CHANGE MASTER TO FOR CHANNEL 'group_replication_applier' executed'. Previous state master_host='<NULL>', master_port= 0, master_log_file='', master_log_pos= 4, master_bind=''. New state master_host='<NULL>', master_port= 0, master_log_file='', master_log_pos= 4, master_bind=''.
2017-03-31T05:10:19.044001Z 3 [Note] Plugin group_replication reported: 'Group Replication applier module successfully initialized!'
2017-03-31T05:10:19.044001Z 7 [Note] Slave SQL thread for channel 'group_replication_applier' initialized, starting replication in log 'FIRST' at position 0, relay log '.\server1-PC-relay-bin-group_replication_applier.000012' position: 4
2017-03-31T05:10:19.044001Z 3 [Note] Plugin group_replication reported: 'auto_increment_increment is set to 7'
2017-03-31T05:10:19.044001Z 3 [Note] Plugin group_replication reported: 'auto_increment_offset is set to 3'
2017-03-31T05:10:19.044001Z 0 [Note] Plugin group_replication reported: 'state 0 action xa_init'
2017-03-31T05:10:19.090801Z 0 [Note] Plugin group_replication reported: 'Successfully bound to 0.0.0.0:24901 (socket=2496).'
2017-03-31T05:10:19.090801Z 0 [Note] Plugin group_replication reported: 'Successfully set listen backlog to 32 (socket=2496)!'
2017-03-31T05:10:19.090801Z 0 [Note] Plugin group_replication reported: 'Successfully unblocked socket (socket=2496)!'
2017-03-31T05:10:19.090801Z 0 [Note] Plugin group_replication reported: 'Ready to accept incoming connections on 0.0.0.0:24901 (socket=2496)!'
2017-03-31T05:10:19.090801Z 0 [Note] Plugin group_replication reported: 'connecting to 192.168.10.206 24901'
2017-03-31T05:10:19.090801Z 0 [Note] Plugin group_replication reported: 'client connected to 192.168.10.206 24901 fd 2520'
2017-03-31T05:10:19.090801Z 0 [Note] Plugin group_replication reported: 'connecting to 192.168.10.206 24901'
2017-03-31T05:10:19.090801Z 0 [Note] Plugin group_replication reported: 'client connected to 192.168.10.206 24901 fd 2540'
2017-03-31T05:10:19.090801Z 0 [Note] Plugin group_replication reported: 'connecting to 192.168.10.206 24901'
2017-03-31T05:10:19.090801Z 0 [Note] Plugin group_replication reported: 'client connected to 192.168.10.206 24901 fd 2552'
2017-03-31T05:10:19.090801Z 0 [Note] Plugin group_replication reported: 'connecting to 192.168.10.206 24901'
2017-03-31T05:10:19.090801Z 0 [Note] Plugin group_replication reported: 'client connected to 192.168.10.206 24901 fd 2564'
2017-03-31T05:10:19.090801Z 0 [Note] Plugin group_replication reported: 'connecting to 192.168.10.206 24901'
2017-03-31T05:10:19.122001Z 0 [Note] Plugin group_replication reported: 'client connected to 192.168.10.206 24901 fd 2576'
2017-03-31T05:10:19.122001Z 0 [Note] Plugin group_replication reported: 'connecting to 192.168.10.206 24901'
2017-03-31T05:10:19.122001Z 0 [Note] Plugin group_replication reported: 'client connected to 192.168.10.206 24901 fd 2500'
2017-03-31T05:10:19.122001Z 0 [Note] Plugin group_replication reported: 'connecting to 192.168.10.150 24901'
2017-03-31T05:10:19.122001Z 0 [Note] Plugin group_replication reported: 'client connected to 192.168.10.150 24901 fd 2592'
2017-03-31T05:10:21.742805Z 0 [Note] Plugin group_replication reported: 'state 4257 action xa_snapshot'
2017-03-31T05:10:21.758405Z 0 [Note] Plugin group_replication reported: 'new state x_recover'
2017-03-31T05:10:21.758405Z 0 [Note] Plugin group_replication reported: 'state 4277 action xa_complete'
2017-03-31T05:10:21.758405Z 0 [Note] Plugin group_replication reported: 'new state x_run'
2017-03-31T05:11:19.044101Z 3 [ERROR] Plugin group_replication reported: 'Timeout on wait for view after joining group'
2017-03-31T05:11:19.045101Z 3 [Note] Plugin group_replication reported: 'Requesting to leave the group despite of not being a member'
2017-03-31T05:11:19.046101Z 3 [ERROR] Plugin group_replication reported: '[GCS] The member is leaving a group without being on one.'
2017-03-31T05:11:49.048817Z 0 [ERROR] Plugin group_replication reported: '[GCS] Timeout while waiting for the group communication engine to exit!'
2017-03-31T05:11:49.049817Z 0 [ERROR] Plugin group_replication reported: '[GCS] The member has failed to gracefully leave the group.'
2017-03-31T05:11:49.051817Z 0 [Note] Plugin group_replication reported: 'state 4330 action xa_terminate'
2017-03-31T05:11:49.052817Z 0 [Note] Plugin group_replication reported: 'new state x_start'
2017-03-31T05:11:49.053818Z 0 [Note] Plugin group_replication reported: 'state 4257 action xa_exit'
2017-03-31T05:11:49.054818Z 0 [Note] Plugin group_replication reported: 'Exiting xcom thread'
2017-03-31T05:11:49.055818Z 0 [Note] Plugin group_replication reported: 'new state x_start'
2017-03-31T05:11:49.056818Z 0 [Warning] Plugin group_replication reported: 'read failed'
2017-03-31T05:11:49.083819Z 0 [Warning] Plugin group_replication reported: '[GCS] The member has left the group but the new view will not be installed, probably because it has not been delivered yet.'
2017-03-31T05:11:54.086105Z 3 [Note] Plugin group_replication reported: 'auto_increment_increment is reset to 1'
2017-03-31T05:11:54.087105Z 3 [Note] Plugin group_replication reported: 'auto_increment_offset is reset to 1'
2017-03-31T05:11:54.088105Z 7 [Note] Error reading relay log event for channel 'group_replication_applier': slave SQL thread was killed
2017-03-31T05:11:54.107107Z 4 [Note] Plugin group_replication reported: 'The group replication applier thread was killed'

I have no idea what`s going on with it!

How to repeat:

myql>start group_replication;
[31 Mar 2017 6:19] nothing radong
I think my network works fine, and the tcpport in opening for incomming!!
[31 Mar 2017 6:25] nothing radong
first configuration file

Attachment: my.ini (application/octet-stream, text), 14.15 KiB.

[31 Mar 2017 6:26] nothing radong
second configuration file

Attachment: my2.ini (application/octet-stream, text), 14.14 KiB.

[7 Apr 2017 23:00] MySQL Verification Team
We're sorry, but the bug system is not the appropriate forum for asking help on using MySQL products. Your problem is not the result of a bug.

Support on using our products is available both free in our forums at http://forums.mysql.com/ and for a reasonable fee direct from our skilled support engineers at http://www.mysql.com/support/

Thank you for your interest in MySQL.