Bug #85688 Replication with SSL return error 2026
Submitted: 29 Mar 2017 16:16 Modified: 21 Feb 0:40
Reporter: Clark Fei Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server: Replication Severity:S1 (Critical)
Version:5.7 OS:CentOS
Assigned to: Bogdan Kecman CPU Architecture:Any

[29 Mar 2017 16:16] Clark Fei
Description:
Replication with SSL keep return error code 2026

Thanks 

How to repeat:
The SSL connection worked with using mysql client like bleow:

mysql -h 1.2.3.4 -u back -p test --ssl-ca=/etc/mysql/ca.pem --ssl-cert=/etc/mysql/client-cert.pem --ssl-key=/etc/mysql/client-key.pem

But with the same SSL files not working in Replication setting:

CHANGE MASTER TO
MASTER_HOST='1.2.3.4',
MASTER_USER='back',
MASTER_PASSWORD='xxxxxx',
MASTER_SSL=1,
MASTER_SSL_CAPATH = '/etc/mysql',
MASTER_SSL_CA = '/etc/mysql/ca.pem',
MASTER_SSL_CERT = '/etc/mysql/client-cert.pem',
MASTER_SSL_KEY = '/etc/mysql/client-key.pem';

log keep showing:
lave I/O for channel '': error connecting to master 'back@1.2.3.4:3306' - retry-time: 60  retries: 1, Error_code: 2026

Master Server:
Centos 6.7
MySQL: 5.7.13
OpenSSL: OpenSSL 1.0.1e-fips 11 Feb 2013 

Slave server:
Centos 6.8
MySQL: 5.7.17
OpenSSL: OpenSSL 1.0.1e-fips 11 Feb 2013
[21 Feb 0:40] Bogdan Kecman
Hi,

Thanks for your report but this is not a bug. Please contact our support team to help you properly configure the system trough our support system or trough the https://forums.mysql.com/

kind regards
Bogdan