Bug #85644 Windows installation from .msi package is inconsistant
Submitted: 27 Mar 2017 9:33 Modified: 4 Apr 2017 9:58
Reporter: Christian Weithøft Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL for Windows: Installer Severity:S1 (Critical)
Version:mysql-installer-community-5.7.17.0 OS:Windows (Windows 10 Pro 64 bit)
Assigned to: CPU Architecture:Any
Tags: msi install, Windows 10

[27 Mar 2017 9:33] Christian Weithøft
Description:
mysqld does not start correctl ...
after doing a full install (first doing a complete uninstall) using a .msi installer. (mysql-installer-community-5.7.17.0.msi)

In the logfile I find the following:

2017-03-27T08:52:21.506236Z 0 [ERROR] Incorrect definition of table mysql.db: expected column 'User' at position 2 to have type char(32), found type char(16).
2017-03-27T08:52:21.506236Z 0 [ERROR] mysql.user has no `Event_priv` column at position 28
2017-03-27T08:52:21.506236Z 0 [ERROR] Event Scheduler: An error occurred when initializing system tables. Disabling the Event Scheduler.

Installing and then continue to run the server works fine, but after a full shutdown/startup of Windows (because of weekend) mysqld does not run. 

How to repeat:
Try to do a full install on a Windows 10 Pro 64 bit, (US version)

After a shutdown / startup mysqld is not working due to database definition error.
[28 Mar 2017 12:30] Chiranjeevi Battula
Hello Christian,

Thank you for the bug report.
I tried to reproduce the issue at my end using  mysql-installer-web-community-5.7.17.0.msi but not seeing any issues with services.
Could you please provide step by step (exact screenshot, stack trace etc. - please make it as private if you prefer) to confirm this issue at our end?

Thanks,
Chiranjeevi.
[31 Mar 2017 7:59] Christian Weithøft
I have been thinking about this and have come to the conclusion that it is unlikely that installation fails. 

The problem is more likely in the import of a database that I do right after installing MySQL.

I will try to verify if I'm right in my conclusion.
[31 Mar 2017 14:01] Christian Weithøft
Hi again

I have verified that the problem is not installation but an import of data. 
Data are imported is a dump from a client system. I did not realise that the original system was a different version of MySQL. The dump file states that it is:

-- MySQL dump 10.13  Distrib 5.5.49, for debian-linux-gnu (x86_64)
--
-- Host: localhost    Database: 
-- ------------------------------------------------------
-- Server version	5.5.49-0ubuntu0.14.04.1

My system is a Windows 10 64 bit, MySql 5.7.17. 

If I insist on doing the import - because I need to make some changes to the database and need to test on a Production like database.

Do I need to install the same MySQL version on my development PC or can I make the import run on a newer MySQL f.ex. by removing the section that cause the problem.

The section that cause the problem is

DROP TABLE IF EXISTS `db`;
/*!40101 SET @saved_cs_client     = @@character_set_client */;
/*!40101 SET character_set_client = utf8 */;
CREATE TABLE `db` (
  `Host` char(60) COLLATE utf8_bin NOT NULL DEFAULT '',
  `Db` char(64) COLLATE utf8_bin NOT NULL DEFAULT '',
  `User` char(16) COLLATE utf8_bin NOT NULL DEFAULT '',
  `Select_priv` enum('N','Y') CHARACTER SET utf8 NOT NULL DEFAULT 'N',
  `Insert_priv` enum('N','Y') CHARACTER SET utf8 NOT NULL DEFAULT 'N',
  `Update_priv` enum('N','Y') CHARACTER SET utf8 NOT NULL DEFAULT 'N',
  `Delete_priv` enum('N','Y') CHARACTER SET utf8 NOT NULL DEFAULT 'N',
  `Create_priv` enum('N','Y') CHARACTER SET utf8 NOT NULL DEFAULT 'N',
  `Drop_priv` enum('N','Y') CHARACTER SET utf8 NOT NULL DEFAULT 'N',
  `Grant_priv` enum('N','Y') CHARACTER SET utf8 NOT NULL DEFAULT 'N',
  `References_priv` enum('N','Y') CHARACTER SET utf8 NOT NULL DEFAULT 'N',
  `Index_priv` enum('N','Y') CHARACTER SET utf8 NOT NULL DEFAULT 'N',
  `Alter_priv` enum('N','Y') CHARACTER SET utf8 NOT NULL DEFAULT 'N',
  `Create_tmp_table_priv` enum('N','Y') CHARACTER SET utf8 NOT NULL DEFAULT 'N',
  `Lock_tables_priv` enum('N','Y') CHARACTER SET utf8 NOT NULL DEFAULT 'N',
  `Create_view_priv` enum('N','Y') CHARACTER SET utf8 NOT NULL DEFAULT 'N',
  `Show_view_priv` enum('N','Y') CHARACTER SET utf8 NOT NULL DEFAULT 'N',
  `Create_routine_priv` enum('N','Y') CHARACTER SET utf8 NOT NULL DEFAULT 'N',
  `Alter_routine_priv` enum('N','Y') CHARACTER SET utf8 NOT NULL DEFAULT 'N',
  `Execute_priv` enum('N','Y') CHARACTER SET utf8 NOT NULL DEFAULT 'N',
  `Event_priv` enum('N','Y') CHARACTER SET utf8 NOT NULL DEFAULT 'N',
  `Trigger_priv` enum('N','Y') CHARACTER SET utf8 NOT NULL DEFAULT 'N',
  PRIMARY KEY (`Host`,`Db`,`User`),
  KEY `User` (`User`)
) ENGINE=MyISAM DEFAULT CHARSET=utf8 COLLATE=utf8_bin COMMENT='Database privileges';
/*!40101 SET character_set_client = @saved_cs_client */;
[4 Apr 2017 9:58] Chiranjeevi Battula
Hello Christian,

Thank you for your feedback.
We're sorry, but the bug system is not the appropriate forum for asking help on using MySQL products. Your problem is not the result of a bug.
Support on using our products is available both free in our forums at http://forums.mysql.com/ and for a reasonable fee direct from our skilled support engineers at http://www.mysql.com/support/
Thank you for your interest in MySQL.

Thanks,
Chiranjeevi.