Bug #85494 [ERROR] unknown variable 'tx_isolation=REPEATABLE-READ'
Submitted: 17 Mar 2017 5:20 Modified: 17 Mar 2017 5:35
Reporter: kfpanda kf Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: Options Severity:S3 (Non-critical)
Version:5.7.17 OS:Any
Assigned to: CPU Architecture:Any

[17 Mar 2017 5:20] kfpanda kf
Description:
Hello,
first,I add "tx_isolation='REPEATABLE-READ'" into my.cnf(section: mysqld)

then,i restart mysql, error occurs in error log:
2017-03-17T05:17:17.903901Z 0 [ERROR] unknown variable 'tx_isolation=REPEATABLE-READ'
2017-03-17T05:17:17.903923Z 0 [ERROR] Aborting

How to repeat:
Hello,
first,I add "tx_isolation='REPEATABLE-READ'" into my.cnf(section: mysqld)

then,i restart mysql, error occurs in error log:
2017-03-17T05:17:17.903901Z 0 [ERROR] unknown variable 'tx_isolation=REPEATABLE-READ'
2017-03-17T05:17:17.903923Z 0 [ERROR] Aborting

Suggested fix:
I hope the variable tx_isolation can be maintained in my.cnf.
[17 Mar 2017 5:35] Umesh Shastry
Hello kfpanda kf,

Thank you for the report.
Marking as duplicate of Bug #70008

Thanks,
Umesh