Bug #85476 Failing to install MySQL 5.7.17 on a clean virtual machine - Ubuntu 14.04 64bit
Submitted: 16 Mar 2017 7:09 Modified: 8 Jun 2018 11:23
Reporter: Jericho Rivera Email Updates:
Status: No Feedback Impact on me:
None 
Category:MySQL Server: Packaging Severity:S3 (Non-critical)
Version:5.7.17 OS:Any
Assigned to: Lars Tangvald CPU Architecture:Any

[16 Mar 2017 7:09] Jericho Rivera
Description:
I basically followed the instructions in the manual - https://dev.mysql.com/doc/mysql-apt-repo-quick-guide/en/#apt-repo-fresh-install, but I'm getting an error every time I install on a fresh VM.

Unpacking mysql-server (5.7.17-1ubuntu14.04) ...
Processing triggers for ureadahead (0.100.0-16) ...
Setting up libnuma1:amd64 (2.0.9~rc5-1ubuntu3.14.04.2) ...
Setting up libaio1:amd64 (0.3.109-4) ...
Setting up mysql-common (5.7.17-1ubuntu14.04) ...
update-alternatives: using /etc/mysql/my.cnf.fallback to provide /etc/mysql/my.cnf (my.cnf) in auto mode
Setting up mysql-community-client (5.7.17-1ubuntu14.04) ...
Setting up mysql-client (5.7.17-1ubuntu14.04) ...
Setting up psmisc (22.20-1ubuntu2) ...
Setting up libmecab2 (0.996-1.1) ...
Setting up mysql-community-server (5.7.17-1ubuntu14.04) ...
update-alternatives: error: unable to read link `/etc/alternatives/my.cnf': Invalid argument
dpkg: error processing package mysql-community-server (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-community-server (= 5.7.17-1ubuntu14.04); however:
  Package mysql-community-server is not configured yet.

dpkg: error processing package mysql-server (--configure):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.19-0ubuntu6.9) ...
Processing triggers for ureadahead (0.100.0-16) ...
Errors were encountered while processing:
 mysql-community-server
 mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

I'll upload a text file with the install steps.

How to repeat:
Launch a clean Ubuntu 14.04 64bit VM (I used LXC in this case)

Follow instructions how to install using apt repo fresh install from manual.
[16 Mar 2017 7:09] Jericho Rivera
command line output for installation steps

Attachment: install.txt (text/plain), 15.55 KiB.

[16 Mar 2017 8:08] Lars Tangvald
Are you able to reproduce this outside lxc?

I couldn't reproduce in docker or a full vm, but we do test on the latter as part of every release anyway.

Do you see any mysql-related errors in the syslog.
Also, which version of dpkg (update-alternatives is part of dpkg) is installed in the container?
[16 Mar 2017 10:43] Jericho Rivera
There are no mysql related errors in the syslog

root@test2:~# grep mysql /var/log/syslog 
root@test2:~# date
Thu Mar 16 10:36:53 UTC 2017
root@test2:~# 
root@test2:~# dpkg --version
Debian `dpkg' package management program version 1.17.5 (amd64).
This is free software; see the GNU General Public License version 2 or
later for copying conditions. There is NO warranty.
[16 Mar 2017 11:32] Jericho Rivera
Same happens on Xenial if installed inside lxc, however I tested installing outside of lxc in Ubuntu Xenial and it worked without any problems. So I guess this has something to do with lxc ? I'll see if I can reproduce the issue with older 5.7 and latest 5.6 as well.
[16 Mar 2017 11:47] Lars Tangvald
Did a test with a xenial amd64 lxc container, and it still worked. Is Ubuntu Xenial the host system you run lxc on?
[16 Mar 2017 11:48] Jericho Rivera
Yes, host system is indeed Ubuntu Xenial
[16 Mar 2017 13:29] Umesh Shastry
No issues observed with the exact steps on freshly VM built Ubuntu 14.04

Attachment: 85476_14_04.results (application/octet-stream, text), 29.35 KiB.

[12 May 2017 6:48] Ronan O' Cathain
Having the same problem with a clean install of mysql-apt-config_0.8.5-1_all.deb onto Debian 8 

dpkg: dependency problems prevent configuration of mysql-server:
 mysql-server depends on mysql-community-server (= 5.7.18-1debian8); however:
  Package mysql-community-server is not configured yet.
[8 May 2018 11:23] Miguel Solorzano
You have the same issue with current release 5.7.22?. Thanks.
[9 Jun 2018 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".