Bug #85451 App crashes when closing tab with no name
Submitted: 14 Mar 2017 18:02 Modified: 15 Mar 2017 0:28
Reporter: Sean Ormbrek Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:6.3.6 OS:Mac OS X (unknown)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter nameless tab crash

[14 Mar 2017 18:02] Sean Ormbrek
Description:
Not sure how this started, but my auto saved connection has a tab with no name.  So when i try to close this tab, i choose "dont save", and the app crashes. I've tried saving it, and that also causes the crash.  So i can never close this tab... and sometimes when i close normal tabs, it also crashes... but i think it is due to this no name tab...

below find my wb.log file and a copy/paste from problem report after app crashed last...

Log file
/Users/seanormbrek/Library/Application Support/MySQL/Workbench/log/wb.log:
10:54:07 [INF][      WBContext]: Parsing application arguments.
10:54:07 [INF][      WBContext]:     /Applications/MySQLWorkbench.app/Contents/MacOS/MySQLWorkbench
10:54:07 [INF][      WBContext]:     -psn_0_2851512
10:54:07 [INF][      Workbench]: Starting up Workbench
10:54:07 [INF][      Workbench]: Loading main window
10:54:07 [INF][   WBContext UI]: Initializing workbench context UI with these values:
	base dir: /Applications/MySQLWorkbench.app/Contents/Resources
	plugin path: /Applications/MySQLWorkbench.app/Contents/PlugIns
	struct path: /Applications/MySQLWorkbench.app/Contents/Resources/grt
	module path: /Applications/MySQLWorkbench.app/Contents/PlugIns:/Applications/MySQLWorkbench.app/Contents/Resources/plugins
	library path: /Applications/MySQLWorkbench.app/Contents/Resources/libraries
	user data dir: /Users/seanormbrek/Library/Application Support/MySQL/Workbench
	open at start: 
	open type: 
	run at startup: 
	run type: 
	Force SW rendering: No
	Force OpenGL: No
	quit when done: No
10:54:07 [INF][      WBContext]: WbContext::init
10:54:07 [INF][            WBA]: Looking for extension modules for WBA...
10:54:07 [INF][            WBA]: 0 extension modules found
10:54:07 [WRN][            grt]: /Applications/MySQLWorkbench.app/Contents/Resources/data/table_templates.xml:21: link 'com.mysql.rdbms.mysql.datatype.timestamp' <object db.SimpleDatatype> key=simpleType could not be resolved
10:54:07 [WRN][            grt]: /Applications/MySQLWorkbench.app/Contents/Resources/data/table_templates.xml:106: link 'com.mysql.rdbms.mysql.datatype.varchar' <object db.SimpleDatatype> key=simpleType could not be resolved
10:54:07 [WRN][            grt]: /Applications/MySQLWorkbench.app/Contents/Resources/data/table_templates.xml:229: link 'com.mysql.rdbms.mysql.datatype.int' <object db.SimpleDatatype> key=simpleType could not be resolved
10:54:07 [WRN][            grt]: /Users/seanormbrek/Library/Application Support/MySQL/Workbench/connections.xml:26: link '7CB45D95-E28C-4E91-B537-A34F5DB8ADDB' <object GrtObject> key=owner could not be resolved
10:54:07 [INF][      WBContext]: System info:
 	MySQL Workbench Community (GPL) for Mac OS X version 6.3.6 CE build 511 (32 bit)
	Configuration Directory: /Users/seanormbrek/Library/Application Support/MySQL/Workbench
	Data Directory: /Applications/MySQLWorkbench.app/Contents/Resources
	Cairo Version: 1.10.2
	OS: unknown
	CPU: 8x Intel(R) Core(TM) i7-4870HQ CPU @ 2.50GHz - 16.00GiB RAM

10:54:07 [INF][    WQE backend]: Found auto-save workspace /Users/seanormbrek/Library/Application Support/MySQL/Workbench/sql_workspaces/Ada_Beta-1.autosave
10:54:07 [INF][    WQE backend]: Found auto-save workspace /Users/seanormbrek/Library/Application Support/MySQL/Workbench/sql_workspaces/Ada_Prod-1.autosave
10:54:07 [INF][    WQE backend]: Found auto-save workspace /Users/seanormbrek/Library/Application Support/MySQL/Workbench/sql_workspaces/Factory_Beta_Aurora_RW-1.autosave
10:54:07 [INF][    WQE backend]: Found auto-save workspace /Users/seanormbrek/Library/Application Support/MySQL/Workbench/sql_workspaces/Forge_Factory_Alpha-1.autosave
10:54:07 [INF][    WQE backend]: Found auto-save workspace /Users/seanormbrek/Library/Application Support/MySQL/Workbench/sql_workspaces/Forge_Factory_Beta-1.autosave
10:54:07 [INF][    WQE backend]: Found auto-save workspace /Users/seanormbrek/Library/Application Support/MySQL/Workbench/sql_workspaces/Forge_Factory_Beta_Aurora-1.autosave
10:54:07 [INF][    WQE backend]: Found auto-save workspace /Users/seanormbrek/Library/Application Support/MySQL/Workbench/sql_workspaces/Forge_Factory_Beta_Aurora-2.autosave
10:54:07 [INF][    WQE backend]: Found auto-save workspace /Users/seanormbrek/Library/Application Support/MySQL/Workbench/sql_workspaces/ie-prod(admin)-1.autosave
10:54:07 [INF][    WQE backend]: Found auto-save workspace /Users/seanormbrek/Library/Application Support/MySQL/Workbench/sql_workspaces/ie-prod(admin)-2.autosave
10:54:07 [INF][    WQE backend]: Found auto-save workspace /Users/seanormbrek/Library/Application Support/MySQL/Workbench/sql_workspaces/ie-prod-1.autosave
10:54:07 [INF][    WQE backend]: Found auto-save workspace /Users/seanormbrek/Library/Application Support/MySQL/Workbench/sql_workspaces/infengdev-1.autosave
10:54:07 [INF][    WQE backend]: Found auto-save workspace /Users/seanormbrek/Library/Application Support/MySQL/Workbench/sql_workspaces/localhost_factory-1.autosave
10:54:13 [INF][      SqlEditor]: Opened connection 'Forge Factory Beta Aurora' to MySQL Community Server (GPL) version 5.6.10
10:54:13 [INF][     AutoCCache]: Initializing autocompletion cache for Forge_Factory_Beta_Aurora

How to repeat:
Not sure how this started, but my auto saved connection has a tab with no name.  So when i try to close this tab, i choose "dont save", and the app crashes. I've tried saving it, and that also causes the crash. 

Suggested fix:
allow closing of no-name tabs
[14 Mar 2017 22:30] Miguel Solorzano
Please try version 6.3.9. Thanks.
[14 Mar 2017 23:15] Sean Ormbrek
I was instructed to download 6.3.9.  I did that and the problem is gone! Please close.  And... THANKS!
[15 Mar 2017 0:28] Miguel Solorzano
Thank you for the feedback.