Bug #85450 mysql odbc does not handle password with "}" charactor for example ab}c
Submitted: 14 Mar 2017 16:05 Modified: 14 Mar 2017 17:14
Reporter: Kevin Zou Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / ODBC Severity:S2 (Serious)
Version:5.3.7 OS:Any
Assigned to: CPU Architecture:Any
Tags: odbc password

[14 Mar 2017 16:05] Kevin Zou
Description:
mysql database supports password with character "}" but odbc driver does not. 

create user abc identified by ab}c

Login through mysql command line is allowed. But not successful through 5.3.7 odbc driver. 

"Connection Failed" Invalid connection string attribute

How to repeat:
create an user in mysql abc identified by ab}c

then try to connect through odbc driver. 

"Connection Failed" Invalid connection string attribute
[14 Mar 2017 16:07] Kevin Zou
error

Attachment: Capture1.PNG (image/png, text), 36.91 KiB.

[14 Mar 2017 17:14] MySQL Verification Team
Thank you for the bug report. Duplicate of bug https://bugs.mysql.com/bug.php?id=76310.