Bug #85438 MySQL crashes automatically very frequently
Submitted: 14 Mar 2017 10:24 Modified: 14 Mar 2017 10:34
Reporter: Rajkumar D Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Server: InnoDB storage engine Severity:S1 (Critical)
Version:5.7.17 OS:Red Hat
Assigned to: CPU Architecture:Any

[14 Mar 2017 10:24] Rajkumar D
Description:
MySQL getting crashed automatically daily very frequently for MySQL 5.7.17

One of our customers got a stack trace of the following type in MySQL 5.6.35 (he claimed it does not happen in a similar box in 5.6.33):

terminate called after throwing an instance of 'std::out_of_range'
  what():  vector::_M_range_check: __n (which is 4294967295) >= this->size() (which is 0)
04:06:45 UTC - mysqld got signal 6 ;
...
Thread pointer: 0x0
...
stack_bottom = 0 thread_stack 0x40000
/usr/sbin/mysqld(my_print_stacktrace+0x33)[0x876d73]
/usr/sbin/mysqld(handle_fatal_signal+0x35c)[0x64089c]
/lib64/libpthread.so.0(+0x10f90)[0x7fecc63d2f90]
/lib64/libc.so.6(gsignal+0x37)[0x7fecc57e8167]
/lib64/libc.so.6(abort+0x16a)[0x7fecc57e95ea]
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.4/libstdc++.so.6(_ZN9__gnu_cxx27__verbose_terminate_handlerEv+0x16d)[0x7fecc60e017d]
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.4/libstdc++.so.6(+0x73fc6)[0x7fecc60ddfc6]
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.4/libstdc++.so.6(+0x74011)[0x7fecc60de011]
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.4/libstdc++.so.6(+0x74228)[0x7fecc60de228]
/usr/lib/gcc/x86_64-pc-linux-gnu/4.9.4/libstdc++.so.6(_ZSt24__throw_out_of_range_fmtPKcz+0x139)[0x7fecc613e869]
/usr/sbin/mysqld[0x9c3e02]
/usr/sbin/mysqld[0x9c51a0]
/usr/sbin/mysqld[0x9c60d1]
/lib64/libpthread.so.0(+0x74a4)[0x7fecc63c94a4]
/lib64/libc.so.6(clone+0x6d)[0x7fecc589c66d]

How to repeat:
Unknown yet

Suggested fix:
Upgrade to the next release or downgrade to the previous release
[14 Mar 2017 10:25] Rajkumar D
Its a critical issue
[14 Mar 2017 10:34] Umesh Shastry
Hello Rajkumar,

Thank you for the report.
This is most likely duplicate of Bug #84940, please see Bug #84940

Thanks,
Umesh