Bug #85419 No snippet edit window showing
Submitted: 12 Mar 2017 8:18 Modified: 14 Jun 2018 15:18
Reporter: Graham Charlton Email Updates:
Status: Verified Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:6.3.9/6.3.10/8.0.11 OS:Mac OS X (Version 10.12.3 (Sierra))
Assigned to: CPU Architecture:Any

[12 Mar 2017 8:18] Graham Charlton
Description:
I seem unable to name snippets when I save one from the query editor window.
Edit Snippets doesn’t open any window that I can see so I can’t name them later.
Snippets are saved to the list and run ok but with no name/heading in bold.
I am able to open them in an older version of workbench and name them there

How to repeat:
From a Query tab, click 'Save current statement of selection to the snippet list'.
No Editor appears but snippet is saved to the list.
Right clip the newly created snippet in the list and choose 'Edit Snippet'.
No editor appears.
Close Workbench and open an older version, edit snippet and close.
Re-open 6.3.9 and the snippet now has a bold name/heading.
[12 Mar 2017 8:20] Graham Charlton
(Should say 'Right click' not clip)
[12 Mar 2017 16:06] MySQL Verification Team
Thank you for the bug report.
[31 Aug 2017 5:56] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=87563  marked as duplicate of this one.
[31 Aug 2017 6:37] Graham Charlton
I cannot understand why this is marked as a duplicate of a timestamp problem when my bug report is about being unable to see the snippet editor window.
Are you just kicking this into the long grass?
[19 Nov 2017 17:12] MySQL Verification Team
https://bugs.mysql.com/bug.php?id=88545 marked as duplicate of this one.
[7 Jan 2018 9:20] Paolo Dini
Using Workbench 6.3.10 on OS X 10.13.2. It's January 2018 and the bug has not been fixed yet :(
[14 Jun 2018 15:18] Graham Charlton
I’ve updated to OS X High Sierra and I’m now using Workbench 8.0.11. Still no scratch edit window for snippets and now right-click on the last two saved snippets does nothing - no options to insert, execute, replace, copy, etc. Save 2 dummy snippets last to access the previous ‘last’ 2.

I tried doing a complete delete of Workbench in Applications and folder ~/Library/Application Support/MySQL/Workbench and then a new install but no change.

At least I can still edit them with Workbench 6.2
[1 Feb 2019 0:05] Russell Hanneken
It appears to me that this was fixed in 8.0.12:

https://github.com/mysql/mysql-workbench/commit/0ee9684a625d7bcd18f149beed4bb754ba7c1272#d...

https://dev.mysql.com/doc/relnotes/workbench/en/news-8-0-12.html#workbench-
8-0-12-bug

I don't suppose this fix could be backported to the 6.3 branch? The 8.0 releases aren't an option for me, as I have to connect to a 5.5 instance of MySQL.