Bug #85135 Unablt to install the sys schema: 'NoneType' object has no attribute 'profile'
Submitted: 22 Feb 2017 19:39 Modified: 11 Mar 2017 12:12
Reporter: Daniel D Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:6.3.9 OS:Microsoft Windows (Windows 10)
Assigned to: CPU Architecture:Any

[22 Feb 2017 19:39] Daniel D
Description:
Unable to install Performance Schema helper (sys schema). It's clean install of lasest version of MySQL Workbench and I connecting to external server via SSH.

Log:
22:28:55 [INF][        WQE.net]: Launching SQL IDE
22:28:56 [INF][        WQE.net]: SQL IDE UI is ready
22:28:59 [INF][     SSH tunnel]: Existing SSH tunnel found, connecting
22:28:59 [INF][wb_admin_control.py:query_server_info:725]: WbAdminControl.connect_sql(): The server version stored in the server instance profile was "None". Changed to the version reported by the server: "5.6.30-1~bpo8+1"
22:28:59 [INF][     SSH tunnel]: Existing SSH tunnel found, connecting
22:29:00 [ERR][wb_admin_perfschema.py:get_installed_sys_version:108]: MySQL error getting sys schema version: ("Table 'sys.version' doesn't exist", 1146)
22:29:00 [INF][wb_admin_control.py:server_polling_thread:569]: Monitoring thread running...
22:29:00 [ERR][wb_admin_perfschema.py:get_installed_sys_version:108]: MySQL error getting sys schema version: ("Table 'sys.version' doesn't exist", 1146)
22:29:02 [INF][     SSH tunnel]: Existing SSH tunnel found, connecting
22:29:06 [ERR][wb_admin_perfschema.py:work:249]: Runtime error when installing the sys schema: 'NoneType' object has no attribute 'profile'
22:29:08 [ERR][wb_admin_perfschema.py:get_installed_sys_version:108]: MySQL error getting sys schema version: ("Table 'sys.version' doesn't exist", 1146)

How to repeat:
1. Connect to server (I connecting to external server via SSH but not sure if that important).
2. Select "Performance Reports".
3. Click "Install Helper".
4. Error occurs "Runtime error when installing the sys schema: 'NoneType' object has no attribute 'profile'" and helper wasn't installed.
[22 Feb 2017 19:53] Daniel D
It worked on "local" connection to the same server. I just made SSH tunnel via other software.

So connecting via SSH is important to reproduce this bug.
[23 Feb 2017 12:00] Miguel Solorzano
Thank you for the bug report. Please provide a screenshot of the error message. Thanks.
[9 Mar 2017 2:46] Tong Wu
i have suffered the same problem. i cant move on because i have to connect to the db on server only by ssh tunnel.
[9 Mar 2017 2:51] Tong Wu
error message screenshot

Attachment: bug screenshot.png (image/png, text), 14.46 KiB.

[9 Mar 2017 15:31] Daniel D
Tong Wu, to workaround issue, you can create tunnel via external software (like Bitvise SSH Client or Putty). Just create local port forwarding from port 3306 to port 3306 and then connect to 127.0.0.1:3306 in MySQL Workbench.
[10 Mar 2017 7:04] Chiranjeevi Battula
Hello Daniel,

Thank you for the bug report.
I'm glad that you found a solution for your problem and let us know if you are still having the issue with complete repeatable steps.

Thank you for your interest in MySQL.

Thanks,
Chiranjeevi.
[11 Mar 2017 12:12] Daniel D
That's not a solution, that's dirty workaround!

In summary, how to repeat error:
1. Connect to external MySQL server using SSH tunnel built-in in Workbench (that's important).
2. External MySQL Server shouldn't have the "Performance Reports Helper" (sys schema) installed (so clean server installation never used with Workbench before).
3. Select "Performance Reports" in Workbench.
4. Click "Install Helper".
5. Error occurs "Runtime error when installing the sys schema: 'NoneType' object has no attribute 'profile'" and helper doesn't installs.

Screenshot of error: https://bugs.mysql.com/file.php?id=25079&bug_id=85135
(thanks Tong Wu for screenshot)
[4 May 2017 8:43] Junwei Han
I have got the same problem.

MySQL Workbench 6.3.9 CE 64 bits on Windows 7

/usr/sbin/mysqld  Ver 5.6.29-log for Linux on x86_64 (MySQL Community Server (GPL))
[8 May 2017 11:39] Junwei Han
MySQL Workbench 6.2.5.0 (32 bits) is good.
[12 May 2017 3:33] Junwei Han
V6.3.8 build 1228 CE (32 bits) is also fine.
[8 Jun 2017 13:11] Marco Groenhof
Same issue when using version 6.3.9 CE build 10690321 (64 bit) on Windows 10 PRO. 
I am also using SSH to connect. Having to open Putty every time and thus using the workaround is not really a nice solution imho.
[16 Jun 2017 18:25] matt w
I have the same issue workbench 6.3.9 build 10690321 CE. I am also connecting with SSH to a remote DB. Eventually just installed it directly on the server and now can use it in workbench.
[17 Jan 2018 8:11] Junwei Han
Version 6.3.10 build 12092614 CE (64 bits) still has the problem.
[9 Feb 2018 22:46] Jan Peterson
I have the same issue with MySQL Workbench 6.3.10 build 12092614 CE (64 bits) Community on MacOS X 10.13.3 High Sierra.

It is definitely related to connecting to the DB via SSH.

If you still can't repeat it (based on the bug status) e-mail me for my contact info and we can get on a hangout so you can see the problem.
[23 Feb 2018 8:43] Mohit Uniyal
Getting same issue, here is what is in the log

12:57:56 [ERR][wb_admin_perfschema.py:work:249]: Runtime error when installing the sys schema: 'NoneType' object has no attribute 'profile'
12:57:58 [ERR][wb_admin_perfschema.py:get_installed_sys_version:108]: MySQL error getting sys schema version: ("Table 'sys.version' doesn't exist", 1146)
[4 Jun 2018 20:23] Andrea Ahumada
https://github.com/mysql/mysql-sys