Bug #85083 Bad shortcut created when upgrading MySQL Workbench on Windows
Submitted: 20 Feb 2017 13:46 Modified: 9 Feb 2018 19:32
Reporter: David Roux Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:6.3.9 OS:Microsoft Windows (8.1)
Assigned to: CPU Architecture:Any

[20 Feb 2017 13:46] David Roux
Description:
Hello,

When upgrading MySQL Workbench x64 from 6.3.8 to 6.3.9 via MySQL Installer, a shorcut named "MySQL Workbench 6.3 CE" is created in the "Start Menu" and links to "C:\Program Files\MySQL\MySQL Workbench 6.3 CE\MySQLWorkbench.X.exe"

This the good folder but "MySQLWorkbench.X.exe" doesn't exist.

There is still the old shorcut linked to "MySQLWorkbench.exe" remaining in the "Start menu" and it works as expected (i.e. it opens Workbench 6.3.9). 

OS: Windows Enterprise 8.1 64 bits
MySQL Installer: 1.4.18.0
MySQL Workbench: 6.3.9

How to repeat:
  - Have Workbench 6.3.8 installed
  - Launch MySQL Installer and check for new update
  - Follow the upgrade process to upgrade from Workbench 6.3.8 to 6.3.9
  - Open your "Start Menu" and see the wrong shortcut.

Suggested fix:
Don't create this bad shortcut.
[20 Feb 2017 13:51] David Roux
Start menu shortcut

Attachment: start_menu.png (image/png, text), 7.34 KiB.

[20 Feb 2017 13:52] David Roux
Shortcut properties details

Attachment: properties.png (image/png, text), 18.51 KiB.

[20 Feb 2017 14:41] Peter Laursen
Reproducible for me.

-- Peter
-- not a MySQL/Oracle person
[20 Feb 2017 14:58] Miguel Solorzano
Thank you for the bug report.
[2 May 2017 13:25] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=86147  marked as duplicate of this one.
[9 Feb 2018 19:32] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.0 release, and here's the changelog entry:

Two shortcuts were created for MySQL Workbench 6.3.9 on Windows when
installed or upgraded with MySQL Installer. Only one of the shortcuts
listed in the Start, All Programs menu was valid.

Thank you for the bug report.