Bug #85050 Workbench crash trying to save the diagram on the network
Submitted: 17 Feb 2017 12:26 Modified: 23 Feb 2017 13:09
Reporter: Isaac Flora Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:6.3.6 OS:Ubuntu
Assigned to: CPU Architecture:Any
Tags: workbench crash

[17 Feb 2017 12:26] Isaac Flora
Description:
I formatted the computer and installed the ubuntu mate.

After the instalation of OS, i installed Workbench, open a existing model.

This model file location is in a local server here in the office, with linux ubuntu server and samba share software. 

When i try to save the Diagram, error occurs:

"Could no save document to pathofserver"
Error writing zip file: Write error: Unsupported operation

The user that I am logged into on the samba server has all the read and write privileges in the file path.

This error occurred only after formatting the computer, otherwise it was working normally. The strange thing is that the same error occurred in another machine that I formatted that is also connected to the same network. Machines that were not formatted save the file normally.

How to repeat:
Install ubuntu mate and try save a diagram file from workbench on shared folder in a ubuntu server with samba share sofware.

Suggested fix:
No suggestions
[17 Feb 2017 12:33] Isaac Flora
error image

Attachment: 16807206_1746181599029577_8633248995273488268_n.jpg (image/jpeg, text), 18.30 KiB.

[17 Feb 2017 12:48] Miguel Solorzano
Please try version 6.3.9. Thanks.
[17 Feb 2017 13:17] Isaac Flora
I tried with version 6.3.9 and the error persists. I have stopped working because of this problem. I tried with the versions: 6.3.9, 6.3.6, it seems that all versions have the same problem.
[17 Feb 2017 13:19] Isaac Flora
Locally the file saves without problems, the problem is when I try to save in the network.
[17 Feb 2017 15:14] Peter Laursen
Doesn't it look like an issue with the OS (orr settings of same) you installed after formatting (Firewall, AppArmor, Samba settings etc. etc.)?

Can you save at all to the location (try with a plain textfile for instance)?

-- Peter
-- not a MySQL/Oracle person
[17 Feb 2017 16:52] Isaac Flora
Yes I can save any file normally, edit and delete, text files, files from my php editor, permissions are normal, but the workbench can not save the diagram on the network. Any other program is saving normally, and I can create, copy, edit and save files manually. Error is occurring only with the workbench software.
Thanks.
[23 Feb 2017 13:09] Umesh Shastry
I'm not seeing this issue while saving model file over shared network, On Win7 with WB 6.3.8/9 and mapped network drive. If you can provide more information, feel free to add it to this bug and change the status back to 'Open'.

Thank you for your interest in MySQL.