Bug #85020 MySQL server will not run on Windows 10 bootcamp
Submitted: 16 Feb 2017 15:13 Modified: 8 May 2017 9:38
Reporter: Mike Kalenuik Email Updates:
Status: Not a Bug Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:5.7.17 OS:Microsoft Windows (Windows 10 mac bootcamp)
Assigned to: CPU Architecture:Any
Tags: bootcamp, Macbook Pro, macos, MYSQL SERVER, Windows 10

[16 Feb 2017 15:13] Mike Kalenuik
Description:
Hi,  I have the new MacBook pro 15 inch with touch bar.  I have a boot camp running on Windows 10 pro with all the recent windows updates.  I use an application the uses an older version of MySQL server as its backbone.  When I tried to install this software I noticed that MySQL failed to properly start and the installation fails when the application tests the server.

After plenty of digging,  My original thoughts were folder permissions in Windows 10 blocking me.  This is not the case as even after making sure nothing is blocking the server still will not start up.

So I moved to compatibility issues,  thinking that maybe a newer version of MySQL would run successfully, I downloaded the community version 5.7.17 to try and install onto my Windows 10 bootcamp.  I am able to get all the way through the installation upto the point where the server tries to start up and configure itself.

Once again the server will not start.

How to repeat:
1.)buy a MacBook pro w/ touchbar
2.) Install windows 10 as bootcamp
3.)update windows
4.)Try to install MySQL

Suggested fix:
Up to this point,  I am not sure what will fix this issue.  It almost seems like perhaps the drivers provided by Apple are conflicting with MySQL.  I can’t see how, but I’m no expert on MySQL so I don’t even know where to start looking.
[17 Feb 2017 15:50] Mike Kalenuik
Changed MaoOs to MacOS in tags
[20 Feb 2017 12:33] Klaus Baumeister
Hello,
I have experienced the same problem. Seems to me it's correlated to InnoDB?

I have installed the MySQL on the same computer running the native MacOS, but not under Windows 10 in the Bootcamp system.

What to do?

Klaus
[20 Feb 2017 12:48] Klaus Baumeister
Sorry for the confusing lines above:
I have MacBook pro 2016 13 inch touch bar with 1 TB harddisk.

On Mac OS X the MySQL runs without any problems. Everything perfect.

On the Windows 10 installed via Bootcamp on the disc, I could not get MySQL 5.7 installed and running. It stops when it tries to run the server.

I could not manage to deactivate InnoDB to find out if it could run under MyISAM only.

Klaus
[22 Feb 2017 12:33] Klaus Baumeister
I have just noticed, that InnoDB cannot be disabled in MySQL 5.7:

...
The --skip-innodb option and its synonyms (--innodb=OFF, --disable-innodb, and so forth) are deprecated. These options have no effect as of MySQL 5.7. because InnoDB cannot be disabled
...
[22 Feb 2017 19:12] Mike Kalenuik
You can try to use an older version of MySQL but you will get the same results.  The server will not start.
[22 Feb 2017 20:23] Klaus Baumeister
But if InnoDB is the source of the problem, then the deactivation of InnoDB and the only usage of MyISAM might start the server?

But I hope Chiranjeevi might find a solution for us? If not, I will try an older version of MySQL.

Somebody might argue why we are using the Windows OS on this nice MacBook Pro. I am working in support and training area and I am so happy to have this multi OS system (Unix, Windows and Mac OS) in one small laptop. It's GREAT!!!!
[22 Feb 2017 20:33] Mike Kalenuik
Unfortunately this is a must for me as the application that I use is only windows based.  I have no choice but to try and figure out why MySQL will not run via windows bootcamp.  I use a proprietary software that I use on a daily basis for work.  This windows based application uses MySQL and rewriting the application is out of the question.  What is strange is that only the new macbook pros are affected by this.  My last MacBook (mid2012) also ran bootcamp with windows 7 and the same software would load up with no problems.

There are only three differences here.  Hardware, drivers, OS (Windows 10, macOS)

I kinda rule out the OS as we have other computers here running windows 10 (non mac computers) and said software will run no problem.

I have also reported this to apple, however they pushed me away as it is an application that runs on windows and not mac.
[27 Feb 2017 11:37] Geir Sagberg
Could this be due to to Macbooks with USB-C using a different Sector Size of 4096 bytes? See this thread: https://twocanoes.zendesk.com/hc/en-us/articles/204433039-Image-Compatibility-between-olde...
and also this one: https://bugs.mysql.com/bug.php?id=28913

I tried setting "innodb_flush_method=normal", to no effect.
[7 Mar 2017 12:49] Chiranjeevi Battula
http://bugs.mysql.com/bug.php?id=85339 marked as duplicate of this one.
[7 Mar 2017 15:11] Filippo Berardo
I have to use my macbook for a windows project and hope this bug will be fixed or i have to choose another DB.
[20 Mar 2017 20:41] Liam Stewart
Hey guys,

This is directly affecting me too :( Macbook pro late 2016 running windows in bootcamp, I have tried 500 different ways to get this installed but it always fails.

Appending the my.ini to contain:

innodb_flush_method=normal

Does help me get a little bit further, and I ran mysqld initialize afterwards in an effort to make it run but I then still always get the logs that the user table is missing etc.

From my amateur efforts at debugging and rectifying this on my machine I think the sector size call is a likely candidate and a good place to start.

I can pretty safely say it is only these machines experiencing this issue at the moment, at least this seems to be true to the best of my googling abilities.

If someone manages to work around this please update the ticket as my ability to work on this laptop is crippled until we can solve it >.<;

Liam
[21 Mar 2017 9:56] Liam Stewart
Sorry to post twice,

As a followup it looks like this is definitely the issue:

https://bugs.mysql.com/bug.php?id=28913
[27 Mar 2017 11:39] Filippo Berardo
I have a macbook with osx and win10 on bootcamp and mysql does not start after installation.

I need Mysql on my macbook!
Please fix it.
[21 Apr 2017 21:30] Generoso Lombardi
Hi, finally I have solved the problem.
I have Macbook Pro 15" with touch bar (late 2016).

Make a fresh installation of mysql when it hang "in service start..."
make this:
open with notepad++ the file my.ini file and to innodb section add this:
#*** INNODB Specific options ***
innodb_buffer_pool_size        = 256M
innodb_log_file_size           = 256M
innodb_thread_concurrency      = 16
innodb_flush_log_at_trx_commit = 2
innodb_flush_method            = normal

Save the file, after 
go a usually on windows
c:\ProgramData\MySQL\MySQL Server5.5\data and cancel this file:
DESKTOP-K1N1S7A.err
ib_logfile0
ib_logfile1
ibdata1

Now you can resume the installation ad yoy see the service start.
Note, If the installation not continue... no problem, close ed remake the installation.
[24 Apr 2017 7:41] Klaus Baumeister
Could somebody succeed to install MySQL on Windows bootcamp with the instructions provided by Generoso Lombardi?

I failed in doing so. Can somebody help?
[24 Apr 2017 7:41] Klaus Baumeister
Could somebody succeed to install MySQL on Windows bootcamp with the instructions provided by Generoso Lombardi?

I failed in doing so. Can somebody help?
[25 Apr 2017 20:55] Andrea Martucci
Very thanks Generoso you are a genius, MySQL work correct now on my Apple MacBook Pro 13 with touch bar.
[25 Apr 2017 21:10] Generoso Lombardi
Hi, thanks Andrea Martucci, your name was familiar apperar to be a Italian style name as my name is...

For Klaus Baumeister, where you have problem with my procedure ?
Have you modified my.ini ?
Can you start the windows service name MYSQL and follow the normal installation, but remember of cancel the files that i have reported in previous post.
I have try also the last version of mysql and with upper procedure it work, very well. I have solved the problem reading the .err file and with help of MariaDB that have same rock solid base, MariaDB is born from a fork of MySQL

If you have problem write to this post, I'm happy of help you.
[26 Apr 2017 7:10] Klaus Baumeister
Dear Generoso,
thanks for your message. So, it seems I am the only stupid one who don't know how to solve the problem :(

yes, I have modified the my.ini
yes, I have deleted the files you've mentioned (in ProgramData...)
yes, I tried to start the service MySQL manually, but it shutsdown immediatly (as before)
yes, I have also tried to install the last version of mysql, but with the same erroneous result.

What is strange to me: as I have modified my.ini quite often when trying to solve the problem:
I wanted to start from scratch - so I delete everything what looks like MySQL on the computer from the hard drive.
But when I reinstall the MySQL software then, I always find the previous (my previously changed) my.ini back in the ProgramData directory.

Seems to me some old files are kept somewhere??? How to get rid of the MYSQL completely??? Any idea?

Thanks for your patience and help!!!
[26 Apr 2017 7:13] Acmen lu
Dear Generoso Lombardi,

I'm working with the new MacBook 15' with touchbar 256GB and meet the same problem. The log showed 87 and 187. After following your instructions the installer does not continue installing, then I cancelled the configuration and restart the installer, clicked the 'reconfiguration' and inputed my root password. but then the installer get into non responsive and I have to end it in task manager.

I'm in a hurry to start the mysql service and get crazy by the problem. Wish you could find ways for me. Thank you very much.
[26 Apr 2017 7:24] Klaus Baumeister
Hi Acmen lu and Generoso,
that is familiar to me! I run into the same problem: when I try to restart the installer and typed the root password, the installer hangs...

Some time ago, I managed to avoid this situation, but I do not remember anymore how I did it :(
[26 Apr 2017 8:12] Generoso Lombardi
Hi, it's very important start from a clean situation.
So, uninstall mysql trought windows panel as normally.
After reboot the computer, with administrative account, delete 
C:\program files\mysql for 64 bit version
or 
C:\program files (x86)\mysql for 32 bit version
You don't have finished,
Go to c:\program data -> you must have hidden files view in property for access to this directory... and delete mysql directory.
After you can start a fresh installation.

Remeber also that when you make start windows service you must set in the property of service that it it was locally and not network service and click on integretation desktop to yes also. 

The step are:
Installation
Service hang
-> modify my.ini
-> delete file write in the upper my post usually (c:\ProgramData\mysql\mysql server\data\*.*)
-> modify the mysql service as (locally) and click integration with desktop or other word (not remember well)
-> start the sercice 
This must solve :)

Sorry for my English but I'm Italian
[26 Apr 2017 9:11] Filippo Berardo
Hi Generoso, 

what do you mean with : 
-> modify the mysql service as (locally) and click integration with desktop or other word (not remember well)

Thank you!
[26 Apr 2017 9:29] Filippo Berardo
Ok i tried all the steps, but no way to start the service.
i have a macbook 64bit.
[26 Apr 2017 9:38] Generoso Lombardi
Service MySQL

Attachment: Schermata 2017-04-26 alle 11.35.56.png (image/png, text), 190.38 KiB.

[26 Apr 2017 9:41] Generoso Lombardi
Clik desktop integration too
Usually it is unclicked how show in photo and it's not a good chance to work.
[26 Apr 2017 13:27] Acmen lu
Dear Generoso Lombardi,

I tried all your given steps and fail to start service.

I guess maybe I'm using a mysql 5.7 installer which is different from yours.

I'll try a 5.5 later.
[26 Apr 2017 13:47] Acmen lu
Thanks Generoso Lombardi,

I've finished starting after changing the installer ver from 5.7 to 5.5

Thank you!
[26 Apr 2017 14:25] Generoso Lombardi
I'm happy to hear another work !!!

For later MySQL 64-bit versions (5.7.X) on GPT partitions you may need to add innodb_use_native_aio = true
to other add that I have write upper.
[26 Apr 2017 14:35] Klaus Baumeister
Hi Acmen Lu,
the current version of MySQL is 5.7.18 - so you have failed to install this version, but after you used Version 5.5.xx you succeeded, yes?
thanks a lot
[26 Apr 2017 14:46] Andrea Martucci
Wonderfull Generoso Lombardi 

adding this line too
innodb_use_native_aio = true

I have successful  installed 5.7.18 64 bit version on my Apple MacBookPro 13,3 with touch bar.

Very, very, very thanks a lot.
[26 Apr 2017 14:48] Generoso Lombardi
Perfect !!!
[26 Apr 2017 16:07] Acmen lu
Klaus Baumeister,

Yes. Now It's running MySQL 5.5

Generoso Lombardi,

Thank you very much again! You're really nice.I am very appreciated.
[27 Apr 2017 6:54] Klaus Baumeister
Hi all,
thanks for all your help. I could also successfully install and run MySQL 5.5!
But, I thought, if its possible to install 5.5, why not to try 5.7.18? I tried it in the same way, as installing 5.5 but it failed. Yes, I have changed/inserted the lines recommended above, deleted the initial files in data Directory and changed the Settings in the MySQL Service tab.

I do not want to list all the log protocol, but here are the first lines mentioning the error:

...
2017-04-27T06:45:58.289252Z 0 [Note] Plugin 'FEDERATED' is disabled.
mysqld: Table 'mysql.plugin' doesn't exist
2017-04-27T06:45:58.289252Z 0 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
2017-04-27T06:45:58.289252Z 0 [Note] Salting uuid generator variables, current_pid: 5540, server_start_time: 1493275557, bytes_sent: 0, 
2017-04-27T06:45:58.304821Z 0 [Note] Generated uuid: '2b8d3954-2b15-11e7-844f-784f43794ad6', server_start_time: 1493281097, bytes_sent: 2291512934096
2017-04-27T06:45:58.304821Z 0 [Warning] No existing UUID has been found, so we assume that this is the first time that this server has been started. Generating a new UUID: 2b8d3954-2b15-11e7-844f-784f43794ad6.
2017-04-27T06:45:58.336073Z 0 [Warning] Gtid table is not ready to be used. Table 'mysql.gtid_executed' cannot be opened.
2017-04-27T06:45:58.336073Z 0 [Warning] Failed to set up SSL because of the following SSL library error: SSL context is not usable without certificate and private key
2017-04-27T06:45:58.336073Z 0 [Note] Server hostname (bind-address): '*'; port: 3306
2017-04-27T06:45:58.336073Z 0 [Note] IPv6 is available.
2017-04-27T06:45:58.336073Z 0 [Note]   - '::' resolves to '::';
2017-04-27T06:45:58.336073Z 0 [Note] Server socket created on IP: '::'.
2017-04-27T06:45:58.351702Z 0 [Warning] Failed to open optimizer cost constant tables

2017-04-27T06:45:58.351702Z 0 [ERROR] Fatal error: Can't open and lock privilege tables: Table 'mysql.user' doesn't exist
2017-04-27T06:45:58.367291Z 0 [ERROR] Aborting
...
...

running mysql_update does fail due to non running mysql Service (I assume)

thanks
[27 Apr 2017 7:54] Generoso Lombardi
For Klaus Baumeister

My configuration above work for all MySQL version also 5.7.18
With 5.6.X and above on GPT Partition you have to set full right account on Windows, in two directory.
C:\Program Files\MySQL
C:\ProgramData\MySQL
Insert your account in the table of permission of Windows, fully and it work.
I have insert a image for example after this post.
[27 Apr 2017 7:55] Generoso Lombardi
Fully Permission

Attachment: Schermata 2017-04-27 alle 09.48.43.png (image/png, text), 1000.46 KiB.

[27 Apr 2017 8:14] Klaus Baumeister
Hi Generoso,
yes, I already had the impression that it seems to be correlated with the access rights. I gave full access rights to the users (especially the one who is installing MySQL)...
But it still fails :(
I will soon go back to the version 5.5 and give up to install 5.7xxx

thanks again!!!!
[27 Apr 2017 13:20] Filippo Berardo
Ciao Generoso

I've tried all steps with my macbook 64bit but no way with 5.7.x

I'l try with 5.5
[27 Apr 2017 13:31] Filippo Berardo
Ciao Generoso

Just finished with 5.5.
IT WORKS!!!!!!!!!!!!!!

Happy.
Thank you
[27 Apr 2017 13:59] Generoso Lombardi
Ciao Filippo, sono felice di avervi aiutato del resto le comunity servono a questo

For not Italian people :)
I am happy to have helped you, the rest of the communities are serving this.

I will investigate the reasons why also mysql 5.7.X work on my macbook pro touchbar 2016
[27 Apr 2017 14:05] Filippo Berardo
Se continui ad investigare mi fai un favore!

In fondo sono solo 2000€ di computer che non servirebbe a niente altrimenti, cosa vuoi che siano!...

English : 
Thank you. 2000€ of a macbook well spent.

:D
Grazie.
[8 May 2017 9:38] Chiranjeevi Battula
Hello Mike Kalenuik,

Thank you for the bug report.
I'm glad that you found a solution for your problem and let us know if you are still having the issue with complete repeatable steps.

Thank you for your interest in MySQL.

Thanks,
Chiranjeevi.
[8 May 2017 22:49] Generoso Lombardi
Hi everyone, I also solved the installation of the latest version of mysql on windows 10 ... now I'm home :) :) :)
Well, let's see.
Many of you can run mysql 5.5 through my instructions but not the 5.7.8 or the latest one. The problem lies in the privileges of the Windows 10 Program Files folder. I always worked the latest version of mysql because I have a microsoft acoount and the logo is done with that account ... but ... da da .... what if I log in as a normal user? MySQL 5.7.8 does not start.
Fortunately there is a very simple solution.
Download the latest version of mysql but the .zip extension and put it in 
c:\
rename to mysql and follow me:
Go to c:\mysql and create two directories
data and uploads 

c:\mysql\md data and press enter
c:\mysql\md plugin and press enter
C:\mysql\bin>mysqld --initialize-insecure

Your MySQL is ready to start without password !!!!!

now, if you want MySQL as a Windows service just write:
C:\>"c:\mysql\bin\mysqld" --install and press enter
go a windows service and click start, now your service start with windows to log-on automaticaly

if you want start mysql to hand from console when you want just write this:
C:\mysql\bin>mysqld --defaults-file=c:\mysql\my.ini

Remember that with insicure method you have to sign a password for root else the logon to database is without password. You can do administrative operation with Workbench :)
[8 May 2017 22:52] Generoso Lombardi
Put this file in c:\mysql directory

Attachment: my.ini (application/octet-stream, text), 14.27 KiB.

[8 May 2017 22:54] Generoso Lombardi
My.ini file is essential for running because it has all my previous edits for run mysql on windows 10 bootcamp
[12 May 2017 2:12] kim seung man kim
Could you explain in detail using the screenshot?
I am not a person who speaks English, so I understand a little bit .... :(
[15 Jun 2017 16:58] Aman Singhal
Thanks a bunch Generoso Lombardi.
I'm using late Macbook Pro(2016) without touch bar model. Couldnt start mysql server in xampp/wampp/mysql server. Kept on throwing the error' Mysqld stopped working'.
As Generoso Lombardi suggested, added lines to Innodb settings in my.ini file and deleted the ibdata1 and log files from /mysql/data.
Worked perfectly!!
[23 Oct 2017 15:36] chuang tony
I have successfully run MySQL in my MacBook
but is from the "Windows to Go " SSD-USB disk

(1) cause the bookcomp windows disk is "not under NTFS or FAT" format, so MySQL will confuse, hope MySQL can correct the disk format issue sooner is better.

(2) don't west time or money to upgrade your MacBook + or w/touch bar, issue is the same, Bootcamp disk is Apple formate, not FAT or NTFS.

(3) only use "Windows to GO" driver with NTFS formate can run MySQL in your MacBook

(4) What is "Windows to go" USB ? may be you can ref https://www.youtube.com/watch?v=g77iw6hl2GU
[11 Nov 2017 13:08] Dominique Ottello
Hi,
Same problem with a user on Windows 10 bootcamp.
MySQL 5.7.19 x64 with command:
mysqld.exe --initialize-insecure

2017-11-06T20:21:45.436527Z 0 [ERROR] InnoDB: Header page consists of zero bytes in datafile: .\ibdata1, Space ID:0, Flags: 0. Please refer to [dev.mysql.com] for how to resolve the issue.
2017-11-06T20:21:45.436527Z 0 [ERROR] InnoDB: Corrupted page [page id: space=0, page number=0] of datafile '.\ibdata1' could not be found in the doublewrite buffer.
2017-11-06T20:21:45.436527Z 0 [ERROR] InnoDB: Plugin initialization aborted with error Data structure corruption
2017-11-06T20:21:45.655300Z 0 [ERROR] Plugin 'InnoDB' init function returned error.
2017-11-06T20:21:45.655300Z 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2017-11-06T20:21:45.655300Z 0 [ERROR] Failed to initialize plugins.

With a file DESKTOP-ND9RBU2.err
-2017-11-07T12:25:58 [ERROR] InnoDB: Operating system error number 87 in a file operation
-2017-11-07T12:25:58 [ERROR] InnoDB: File .\ib_logfile101: 'aio write' return OS error 187.Cannot continue operation
-2017-11-07T12:25:58 [ERROR] InnoDB: Cannot continue operation

Result of command fsutil fsinfo ntfsinfo c: is
Octets par secteur: 4096
Octets par secteur physique : 4096
Octest par cluster: 4096
Octets par segment d'enreg. de fich. : 4096

that is a 4K native factory format.
No problem with 512 or 512E factory format.
[11 Nov 2017 13:29] Shane Bester
https://bugs.mysql.com/bug.php?id=28913
(Running MySQL data on a GPT drive?)
[28 Nov 2017 19:51] Dayo Okesola
Thanks Generoso
[19 Jan 3:57] Brendan Corcoran
Why is this marked as "Not a Bug"?????

This does not only affect Macs running bootcamp? I have a 2017 Dell XPS 15 with 1TB SSD set to 4k sectors, and I cannot install MySQL because of this bug.
[24 Jan 16:35] mark lewis
okay! after three days of swearing and throwing things around in a tantrum, I finally got MySQL Server 5.7.21 to work on my brand new MacBook pro running windows 10 creators editions on bootcamp. Huge thanks to all the guys in this thread for solving this.

here's my procedure:
1) downloaded the latest MySQL server 5.7.21 installer (not the whole community installer) and installed it using the standard setting. It always fails for the configuration at the initialise database point. cancel set up and finish. I selected the option to load MySQL when the computer boots up.

2) set folders to show hidden items

3) go to Bootcamp - Program Data (now not hidden) - MySQL - MySQL Server 5.7 and replace the my.ini with the one posted in this thread

4) go to data folder at the same location and delete basically everything that's in there

5) set the folder permissions for MySQL Server 5.7 within the Program Data - MySQL folder so that it is no longer read only, and also set the security so that CREATOR OWNER  is set to FULL CONTROLL, then apply that.

Set the permissions for the Program Files - MySQL - MySQL Server 5.7  folder the same as the one we just did in the Program Data folder.

6) reboot computer

7) downloaded and install MySQL workbench community 6.3.10 x64. When done simply check server status is RUNNING

done (at last)

it seems the stumbling block for me was when adjusting permissions to FULL
[28 Jan 17:49] Martin Pelletier
Same configuration, Macbook Pro with touch bar, running Windows 10 under bootcamp, same bug (for lack of a better word).

I haven't tried going back to 5.5 yet. Is there a preferred setup for the workarounds mentioned to work? 32bits or 64bits?
[4 Feb 15:24] Generoso Lombardi
There isn't a prefered installation to work.
Follow the instruction above and it work !
[26 Feb 9:23] Vincent Benedict Castro
Good day. 

How do I make this work if I am using XAMPP to start MySQL?

I made the entire C:\xampp folder full control
I placed the attached my.ini file inside C:\xampp\mysql\bin 

Still getting an error.

Your advise will be highly appreciated. 

Ty
[26 Feb 10:06] Generoso Lombardi
The step are:
Installation
Service hang
-> modify my.ini
-> delete file write in the upper my post usually (c:\ProgramData\mysql\mysql server\data\*.*)
-> modify the mysql service as (locally) and click integration with desktop or other word (not remember well)
-> start the sercice 
This must solve :)
[26 Feb 19:26] Vincent Benedict Castro
Generoso Lombardi,

I edited your attached my.ini file to point to xampp folder. 

started the service manually and now it is working. 

Grazzie Mille!

Vincent
[3 May 22:00] Kendall Bennett
Just ran into this same problem installed 5.7.22 onto a fresh install of Windows 10 v1803 in a boot camp partition. The solution that worked for me was to make sure this value was changed:

innodb_flush_log_at_trx_commit=2

We normally run on developer boxes with this set to 0, and it turns out that both 0 and 1 do not work in this scenario, which is clearly a bug in MySQL. We have other developers using boot camp with Windows 10 and it runs fine so it only happens in some instances.
[7 Aug 18:23] Noel Paguio
After struggling with this issue. I came up to successfully running the mysqld service from my wamp server. What i did is just follow Generoso's first solution above. adding/replacing some settings on my.ini not replacing the my.ini itself provided by him as because wamp server uses different paths for default directories and log location. and then i did the allow full control previllage on wamp server folder and removed the read only attribute. after doing that it did not work but i have a new error from my mysql.log showing that mysql.plugin cannot be opened and needs to be updated (same issue on one of the above's commenter). so what i did is googling the missing piece and found out that uncommenting the line "skip-grant-tables" worked finally. ps, after getting the mysql.plugin error, i did not remove the files iside the data folder, just uncomment "skip-grant-tables" from my.ini.

hope this helps the dude with the same problem as mine and to others that will encounter this problem.
[1 Nov 21:56] Evren Ozcan
Hi Generoso Lombardi,

I've signed up to be able to thank you.
I tried for days to solve this problem.
Finally, everything's ok now, many thanks bro

My system
MacBook Pro 13" with Touch Bar
Mojave / Bootcamp Windows 10 pro and Mysql 5.6.41