Bug #8491 "Table 'rsa.Vote' doesn't exist" w/ CONCUR_UPDATEABLE
Submitted: 13 Feb 2005 22:10 Modified: 31 Mar 2014 8:26
Reporter: Steve Ryder Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / J Severity:S1 (Critical)
Version:3.23.58 OS:Linux (Linux Fedora 2)
Assigned to: Alexander Soklakov CPU Architecture:Any

[13 Feb 2005 22:10] Steve Ryder
Description:
General error message from server: "Table 'rsa.Vote' doesn't exist"
with ResultSet.CONCUR_UPDATABLE on a query that works with default type. 

The default database is "reqs" and reqs.Vote does exist!  "rsa" is another database on the system, and I have applications running (and updating) against it using similar Java code.  

full log in reverse sequence follows:
2005-02-13 15:03:22: update(1) SQL exception: null
2005-02-13 15:03:22:JsrSQL: Assume addition
2005-02-13 15:03:22: moveToInsertRow Result Set not updatable.This result set must come from a statement that was created with a result set type of ResultSet.CONCUR_UPDATABLE, the query must select only one table, and must select all primary keys from that table. See the JDBC 2.1 API Specification, section 5.6 for more details.
2005-02-13 15:03:22: exception: General error message from server: "Table 'rsa.Vote' doesn't exist"
2005-02-13 15:03:22: setSelect: SELECT * FROM Vote WHERE UGREQNO='SOMVSS93052' AND WhoID =104 AND VoteID > 0
2005-02-13 15:03:22: 1 rows 7 cols found in result set
2005-02-13 15:03:22: setSelect: SELECT * FROM Vote WHERE UGREQNO='SOMVSS93052' AND WhoID =104 AND VoteID > 0
2005-02-13 15:03:22:USE reqs has no results.
2005-02-13 15:03:22:Connection to jdbc/MySql established.

How to repeat:
http://app.jsrsys.com/TestApp/reqsLogin.jsp?u=JimRyder&x=11IQ&p=MVSS

click a pushbutton on first line, press Vote button.  

To see log messages after doing above try:
http://app.jsrsys.com/TestApp/getLog.jsp

I can email the JsrSQL Java source if that would help.
[14 Feb 2005 13:04] Aleksey Kishkin
Sorry don't have and idea how to reproduce it. Can you attach repeatable test case?
[15 Mar 2005 0:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[27 Mar 2005 21:38] Steve Ryder
I was expecting an email if you wanted feedback.  Not having gotten any (and not finding this one bacause I was only searching Active entries), I created a new bug that is a better description, and also has a test case.

See bug #9423.  The description is less wordy as I understand the problem better.  I also include the code for the test cast jsp itself, as well as the Java class that sees the exception.  The test case is: http://app.jsrsys.com/TestApp/dbTest.jsp
It recreates the error, and has a link to the exception log as well as all relevant source code.   Since I was able to code a workaround (execUpdate) I have downgraded to S3.
[27 Mar 2005 21:41] Steve Ryder
See 9423 for test case and improved description.
[31 Mar 2014 8:26] Alexander Soklakov
This bug is marked as duplicate of Bug#9423.