Bug #84851 Cannot append numbers that are the result of formulas
Submitted: 6 Feb 2017 23:04 Modified: 5 May 2017 22:23
Reporter: Zachary Bodinger Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL for Windows: MySQL for Excel Severity:S2 (Serious)
Version:1.3.6 OS:Microsoft Windows (7)
Assigned to: CPU Architecture:Any
Tags: append, import, null, numeric

[6 Feb 2017 23:04] Zachary Bodinger
Description:
When trying to append numeric data, there is no way to use formulas in excel to generate the numbers without them being regarded as a string. 

How to repeat:
enter a formula in a cell, such as =if(G3 = 5, 3, "") in cell A1 and then try to append that cell to an existing column that has type 'Numeric'

Suggested fix:
There should be functionality to read "" as null in numeric columns, or to allow for some indication that a numeric cell should be regarded as null without having to delete the formulas in the cells. For example, one could type the word NULL or null to indicate that a numeric cell should be regarded as null.
[7 Feb 2017 6:29] Chiranjeevi Battula
Hello Zachary Bodinger,

Thank you for the bug report.
I could not see any issues in importing/append data using with MySQL for Windows: MySQL for Excel 1.3.8 version.
This is most likely duplicate of Bug #73505, please see Bug #73505.

Thanks,
Chiranjeevi.
[7 Feb 2017 6:29] Chiranjeevi Battula
Screenshot

Attachment: 84851.JPG (image/jpeg, text), 193.33 KiB.

[7 Feb 2017 6:30] Chiranjeevi Battula
excel

Attachment: 84851_1.JPG (image/jpeg, text), 45.27 KiB.

[7 Feb 2017 8:46] Javier Treviño
Confirmed in Excel 1.3.6 the problem, this is not a duplicate bug, this rather got broken again in a recent version.
[7 Feb 2017 8:53] Javier Treviño
Posted by developer:
 
Fixed a problem where empty string values mixed in an Excel column's data that is used in an Export or Append Data operation cause the generated SQL queries to have no value, instead of an "empty" value corresponding to the target column's data type (e.g. 0 for integer, false for bool if the column does not allow null values, or null otherwise).
[7 Feb 2017 18:09] Zachary Bodinger
Javier -- was that posted fix from a developer for an upcoming release?
[7 Feb 2017 19:16] Javier Treviño
Posted by developer:
 
Right, the fix will be included in the upcoming 1.3.7 version.
We can't disclose release dates, so I suggest you to monitor releases using the MySQL Installer for Windows or in the MySQL forums.
[5 May 2017 21:57] Rafael Antonio Bedoy Torres
Posted by developer:
 
Fixed on 1.3.7 build 2
[5 May 2017 22:23] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL for Excel 1.3.7 release, and here's the changelog entry:

Empty string values within Excel column data that were used in an export
or append-data operation caused the generated SQL queries to have no
value, instead of an empty value corresponding to the data type of the
target column (for example: 0 for Integer; false for Bool if the column
does not allow NULL values, or NULL otherwise).

Thank you for the bug report.