Bug #84848 MySQL Server not in apt repository even though it's still GA
Submitted: 6 Feb 2017 18:50 Modified: 14 Mar 2017 9:38
Reporter: Feanil Patel Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Package Repos and Docker Images Severity:S2 (Serious)
Version:5.6 OS:Ubuntu
Assigned to: CPU Architecture:Any
Tags: apt repository ubuntu missing 5.6

[6 Feb 2017 18:50] Feanil Patel
Description:
MySQL 5.6 is still GA but the debian files are not available for Ubuntu 16.04

How to repeat:
1. On a Ubuntu 16.04(xenial) machine, add the following to /etc/apt/sources.list

"deb http://repo.mysql.com/apt/ubuntu/ xenial mysql-5.6"

2. Add the MySQL Apt repo key

`apt-key adv --keyserver keyserver.ubuntu.com --recv 8C718D3B5072E1F5

3. Run `apt update`

4. apt install mysql-server-5.6

Suggested fix:
Upload the mysql 5.6 client and server packages to the apt repository.
[7 Feb 2017 12:57] Umesh Shastry
Hi Feanil Patel,

Thank you for the report.
I haven't tried it but did you try creating /etc/apt/sources.list.d/mysql.list and then adding the entry? Does this helps? Please confirm

deb http://repo.mysql.com/apt/ubuntu/ xenial mysql-5.6

Please see https://dev.mysql.com/doc/mysql-apt-repo-quick-guide/en/#repo-qg-apt-repo-errors-sources-l...

Thanks,
Umesh
[8 Mar 2017 1:00] Bugs System
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
[8 Mar 2017 16:36] Feanil Patel
Hello, I tried this on a fresh machine and still saw the error.  

```
root@0699612decdf:/# apt install mysql-server-5.6
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package mysql-server-5.6 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  percona-xtradb-cluster-server-5.6 percona-server-server-5.6 mysql-testsuite-5.7 mariadb-server-10.0
  mysql-server-core-5.7 mysql-server-5.7

E: Package 'mysql-server-5.6' has no installation candidate
```
[14 Mar 2017 9:38] Umesh Shastry
You are right, even I had issues while trying.
Lets call this as duplicate of Bug #83046 for now.

Thanks,
Umesh