Bug #84675 Workbench Crashes unexpectedly
Submitted: 25 Jan 23:14 Modified: 25 Jan 23:38
Reporter: Kuthair Habboush Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:6.3.4 OS:Mac OS X (macOS Sierra 10.12.3)
Assigned to:
Tags: WBBugReporter

[25 Jan 23:14] Kuthair Habboush
Description:
After upgrading to latest version of Mac OS X:   macOS Sierra 10.12.3.

MySQL Workbench crashes unexpectedly when closing tabs or closing dialogs. For example, open a Model, then open to edit a View from inside the model. Without making any changes, close the Edit View window and Workbench crashes.

This also occurs when closing normal SQL Query tabs -- usually only when unchanged -- but not always.

How to repeat:

1. Open an existing Model.

2. Double-click a VIEW in the model to edit it's contents.

3. Without making any changes, close the Edit View window.

4. MySQL Workbench CRASHES.

Suggested fix:
Please stop Workbench from CRASHING.
[25 Jan 23:15] Kuthair Habboush
Workbench LOG File

Attachment: wb.log (application/octet-stream, text), 2.81 KiB.

[25 Jan 23:38] Miguel Solorzano
Thank you for the bug report. Duplicate of http://bugs.mysql.com/bug.php?id=83658.