Bug #84553 MySQL workbench locks up
Submitted: 18 Jan 13:16 Modified: 18 Jan 19:42
Reporter: austin woz Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:6.3.8 OS:Mac OS X (10.12.2)
Assigned to:

[18 Jan 13:16] austin woz
Description:
Connecting workbench 6.3.8 on MacOS to RDS 5.7.x via SSH (using OS terminal to provide the SSH tunnel)
Workbench appears to be functioning until I execute a query, I get indicator rating indicator in tab to show query executing, but the Action pane is empty. Normally I expect the action pane to show the executed query with execution times. But no nothing. 
I have rolled back MySQL versions, I have better luck with 6.3.4 but then suffer other issues making it unusable. Upgrade to 6.3.5 and I have this issue. 
Sometimes it works for a period of time and I can execute queries, but then it will stop. 
I know this bug report is flaky, I have no idea what extra information I can provide to assist, I have checked the logs and nothing important. 
I have exactly the same issue on a second mac laptop I have. 
I have installed NaviCat and that is working fine so I know it is not a network or connection issue. 
I am missing Workbench, I really hope this gets fixed. 

How to repeat:
workbench 6.3.8 on MacOS to RDS 5.7.x connected to 127.0.0.1 to a port that tunnels to RDS. Port tunnel created through the OS terminal app/

Execute queries until it stops working. 

I have to force quit Workbench to close. 
I have tried deleting the Workbench settings in ~/Library/Application Support/MySQL/Workbench/
[18 Jan 13:19] austin woz
I made a typo. 
I get rotating indicator in tab to show query executing..

The action pane is completely empty, it does not even show the executed query less the output times.
[18 Jan 13:21] austin woz
another typo

I have rolled back MySQL Workbench versions...
[18 Jan 16:54] Miguel Solorzano
Thank you for the bug report. Which exactly MAC OS version are you running WorkBench. Thanks.
[18 Jan 17:42] austin woz
running on Mac 10.12.2, fairly sure I had this issue on 10.12.1 as well
[18 Jan 19:42] Miguel Solorzano
Thank you for the feedback. Duplicate of http://bugs.mysql.com/bug.php?id=83658.