Bug #84483 When I want to close a tab and then select 'Don't save' workbench crashes
Submitted: 12 Jan 11:17 Modified: 12 Jan 13:55
Reporter: Žiga Elsner Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S5 (Performance)
Version:6.3.8 OS:Mac OS X (macOS 10.12.x Sierra)
Assigned to:
Tags: WBBugReporter

[12 Jan 11:17] Žiga Elsner
Description:
----[For better reports, please attach the log file after submitting. You can find it in /Users/zigaelsner/Library/Application Support/MySQL/Workbench/log/wb.log]:

11:57:25 [INF][      Workbench]: Starting up Workbench
11:57:25 [INF][      WBContext]: Parsing application arguments.
11:57:25 [INF][      WBContext]:     /Applications/MySQLWorkbench.app/Contents/MacOS/MySQLWorkbench
11:57:25 [INF][   WBContext UI]: Initializing workbench context UI with these values:
	base dir: /Applications/MySQLWorkbench.app/Contents/Resources
	plugin path: /Applications/MySQLWorkbench.app/Contents/PlugIns
	struct path: /Applications/MySQLWorkbench.app/Contents/Resources/grt
	module path: /Applications/MySQLWorkbench.app/Contents/PlugIns:/Applications/MySQLWorkbench.app/Contents/Resources/plugins
	library path: /Applications/MySQLWorkbench.app/Contents/Resources/libraries
	user data dir: /Users/zigaelsner/Library/Application Support/MySQL/Workbench
	open at start: 
	open type: 
	run at startup: 
	run type: 
	Force SW rendering: No
	Force OpenGL: No
	quit when done: No
11:57:25 [INF][      WBContext]: WbContext::init
11:57:25 [INF][            WBA]: Looking for extension modules for WBA...
11:57:25 [INF][            WBA]: 0 extension modules found
11:57:26 [WRN][            grt]: /Applications/MySQLWorkbench.app/Contents/Resources/data/table_templates.xml:21: link 'com.mysql.rdbms.mysql.datatype.timestamp' <object db.SimpleDatatype> key=simpleType could not be resolved
11:57:26 [WRN][            grt]: /Applications/MySQLWorkbench.app/Contents/Resources/data/table_templates.xml:106: link 'com.mysql.rdbms.mysql.datatype.varchar' <object db.SimpleDatatype> key=simpleType could not be resolved
11:57:26 [WRN][            grt]: /Applications/MySQLWorkbench.app/Contents/Resources/data/table_templates.xml:229: link 'com.mysql.rdbms.mysql.datatype.int' <object db.SimpleDatatype> key=simpleType could not be resolved
11:57:26 [WRN][            grt]: /Users/zigaelsner/Library/Application Support/MySQL/Workbench/connections.xml:29: link 'ABEC55C9-4992-490F-8E8D-70815D091B5D' <object GrtObject> key=owner could not be resolved
11:57:26 [INF][      WBContext]: System info:
 	MySQL Workbench Community (GPL) for Mac OS X version 6.3.8 CE build 1228 (64 bit)
	Configuration Directory: /Users/zigaelsner/Library/Application Support/MySQL/Workbench
	Data Directory: /Applications/MySQLWorkbench.app/Contents/Resources
	Cairo Version: 1.10.2
	OS: macOS 10.12.x Sierra
	CPU: 4x Intel(R) Core(TM) i5-5250U CPU @ 1.60GHz - 8.00GiB RAM

11:57:26 [INF][    WQE backend]: Found auto-save workspace /Users/zigaelsner/Library/Application Support/MySQL/Workbench/sql_workspaces/localhost-2.autosave
11:57:26 [INF][    WQE backend]: Found auto-save workspace /Users/zigaelsner/Library/Application Support/MySQL/Workbench/sql_workspaces/omega.development-1.autosave
11:57:26 [INF][    WQE backend]: Found auto-save workspace /Users/zigaelsner/Library/Application Support/MySQL/Workbench/sql_workspaces/omega.live-1.autosave
11:57:26 [INF][    WQE backend]: Found auto-save workspace /Users/zigaelsner/Library/Application Support/MySQL/Workbench/sql_workspaces/sara.development-1.autosave
11:57:26 [INF][    WQE backend]: Found auto-save workspace /Users/zigaelsner/Library/Application Support/MySQL/Workbench/sql_workspaces/sara.live-1.autosave
11:57:29 [INF][     SSH tunnel]: Starting tunnel
11:57:29 [INF][     SSH tunnel]: Existing SSH tunnel not found, opening new one
11:57:29 [INF][     SSH tunnel]: Opening SSH tunnel to 185.148.72.149:22
11:57:30 [INF][     SSH tunnel]: TunnelManager.wait_connection returned OK
11:57:30 [INF][sshtunnel.py:set_keepalive:506]: SSH KeepAlive setting skipped.
11:57:30 [INF][     SSH tunnel]: SSH tunnel connect executed OK
11:57:30 [INF][      SqlEditor]: Opened connection 'omega.development' to MariaDB Server version 5.5.52-MariaDB
11:57:30 [INF][     AutoCCache]: Initializing autocompletion cache for omega.development
12:02:24 [WRN][      Workbench]: set_view_title called for undocked view

How to repeat:
1. Close a tab
2. Don't save
3. Workbench crashes

I had the same problem when i wanted select data from table. (SELECT * FROM table)

I fixed this by uncheck SSL on connection configuration.

Fix was also if I had open two connections at the same time.
[12 Jan 13:55] Miguel Solorzano
Thank you for the feedback. Duplicate of http://bugs.mysql.com/bug.php?id=83658.