Bug #84458 Rename "cuted fields"
Submitted: 10 Jan 2017 13:15 Modified: 12 Jan 2017 16:10
Reporter: Steinar Gunderson Email Updates:
Status: Closed Impact on me:
Category:MySQL Server: Optimizer Severity:S3 (Non-critical)
Version: OS:Any
Assigned to: CPU Architecture:Any

[10 Jan 2017 13:15] Steinar Gunderson
THD contains a field called count_cuted_fields. This is horribly named, for two reasons; it is not a count (it's an enum defining behavior), and the fields are not cute. The assumption is that someone did not know how to conjugate the verb "to cut".

We should rename this to something understandable; I'm picking check_for_truncated_fields. Other uses of cuted_fields will be renamed accordingly.

How to repeat:

Suggested fix:
[12 Jan 2017 16:10] Paul DuBois
Posted by developer:
Fixed in 8.0.1.

Code cleanup. No changelog entry needed.