Bug #84446 MySQL Workbench intermittently hangs when interacting with queries/results
Submitted: 9 Jan 9:46 Modified: 9 Jan 12:10
Reporter: Paul Connolley Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:6.3.8 OS:Mac OS X (macOS Sierra 10.12.2)
Assigned to:

[9 Jan 9:46] Paul Connolley
Description:
Since upgrading to 6.3.8, the application will frequently hang when running a query in a tab. There's no indication why it is hanging and the process doesn't appear to have crashed.

In addition, the rest of the application becomes unresponsive too and there is no way to cancel the current action.

The only way to recover is to force quit the application and restart.

I will attach the current wb.log file which contains the most recent incident. I opened Workbench, connected to the server and then tried to open the rows on a 50 row table.

How to repeat:
Open Workbench on macOS Sierra 10.12.2
Connect to a database
Open the table
Workbench may or may not hang
[9 Jan 12:10] Miguel Solorzano
Thank you for the bug report. Duplicate of http://bugs.mysql.com/bug.php?id=83658.