Bug #8444 Date and time of the server start isn't written to the error log
Submitted: 11 Feb 2005 16:22 Modified: 3 Mar 2005 18:55
Reporter: Victoria Reznichenko Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server Severity:S3 (Non-critical)
Version:4.0 and up OS:Microsoft Windows (Windows)
Assigned to: Jim Winstead CPU Architecture:Any

[11 Feb 2005 16:22] Victoria Reznichenko
Description:
On Windows if MySQL server is running with --skip-innodb option date and time of the server start isn't written to the error log file.

mysqld-opt: ready for connections.
Version: '4.0.23-log'  socket: ''  port: 3306  Source distribution
050211 19:21:19 mysqld-opt: Normal shutdown

050211 19:21:19 mysqld-opt: Shutdown Complete

If I start MySQL server without --skip-innodb option:

050211 19:22:07  InnoDB: Started
mysqld-opt: ready for connections.
Version: '4.0.23-log'  socket: ''  port: 3306  Source distribution
050211 19:22:12 mysqld-opt: Normal shutdown

050211 19:22:12  InnoDB: Starting shutdown...
050211 19:22:13  InnoDB: Shutdown completed
050211 19:22:13 mysqld-opt: Shutdown Complete

How to repeat:
1. add skip-innodb to the my.cnf(my.ini)
2. start MySQL server and then shutdown it
[11 Feb 2005 19:01] Jim Winstead
This is not a bug, and it has nothing to do with Windows or InnoDB. There is never a general timestamped startup message logged.
[11 Feb 2005 19:29] Jim Winstead
Patch will add timestamp to the 'ready for connections' message.
[14 Feb 2005 23:45] Jim Winstead
Patch needs more work.
[23 Feb 2005 2:41] Jim Winstead
I made a new patch for this, just for the 5.0 tree this time because it changes an error message.
[24 Feb 2005 10:17] Alexander Barkov
Ok to push.
[3 Mar 2005 18:40] Jim Winstead
Pushed, will be in 5.0.3. This message is now also printed to stderr instead of stdout.
[3 Mar 2005 18:55] Paul Dubois
Noted in 5.0.3 changelog.