Bug #84407 MySQL Workbench crashes after closing auto-saved connection
Submitted: 4 Jan 15:45 Modified: 4 Jan 15:52
Reporter: Krzysztof Wilk Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S3 (Non-critical)
Version:6.3.8 OS:Mac OS X (Sierra 10.12.2.)
Assigned to:

[4 Jan 15:45] Krzysztof Wilk
Description:
On my machine MySQL Workbench crashes each time after execute the following steps after closing saved MySQL Connection tab.

Even though connection is closed successfully rotating cursor remains and blocks entire application.

Only force quit (or killing its process) closes Workbench properly.

How to repeat:
1. open MySQL Workbench
2. open saved MySQL connection to MySQL 5.7.16 running in Docker container (database user root)
3. set one of database as default schema
4. run simple query such as 'show tables;'
5. after receiving results in Results grid close Query tab
6. close connection tab
[4 Jan 15:52] Miguel Solorzano
Thank you for the bug report. Duplicate of http://bugs.mysql.com/bug.php?id=83658.