Bug #84386 infinite loop when closing a SQL Editor tab
Submitted: 2 Jan 16:04 Modified: 2 Jan 16:36
Reporter: 偽 名 Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:6.3.8 OS:Mac OS X (macOS 10.12.x Sierra)
Assigned to:
Tags: WBBugReporter

[2 Jan 16:04] 偽 名
Description:
With the following reproducing process, MySQL Workbench seems to run into an infinite loop.
- rainbow cursor appears
- "Activity Monitor" says that MySQL Workbench is not responding

===

During the loop, "Console.app" reports the following log, issued by kernel, very frequently(over 1000 times per sec)

AMFI: allowing exception handler for 'MySQLWorkbench' (35174) because the process is not restricted.

===

~/Library/Application Support/MySQL/Workbench/log/wb.log says...

00:15:33 [INF][      Workbench]: Starting up Workbench
00:15:33 [INF][      WBContext]: Parsing application arguments.
00:15:33 [INF][      WBContext]:     /Applications/MySQLWorkbench.app/Contents/MacOS/MySQLWorkbench
00:15:33 [INF][   WBContext UI]: Initializing workbench context UI with these values:
        base dir: /Applications/MySQLWorkbench.app/Contents/Resources
        plugin path: /Applications/MySQLWorkbench.app/Contents/PlugIns
        struct path: /Applications/MySQLWorkbench.app/Contents/Resources/grt
        module path: /Applications/MySQLWorkbench.app/Contents/PlugIns:/Applications/MySQLWorkbench.app/Contents/Resources/plugins
        library path: /Applications/MySQLWorkbench.app/Contents/Resources/libraries
        user data dir: /Users/username/Library/Application Support/MySQL/Workbench
        open at start: 
        open type: 
        run at startup: 
        run type: 
        Force SW rendering: No
        Force OpenGL: No
        quit when done: No
00:15:33 [INF][      WBContext]: WbContext::init
00:15:36 [INF][            WBA]: Looking for extension modules for WBA...
00:15:36 [INF][            WBA]: 0 extension modules found
00:15:36 [WRN][            grt]: /Applications/MySQLWorkbench.app/Contents/Resources/data/table_templates.xml:21: link 'com.mysql.rdbms.mysql.datatype.timestamp' <object db.SimpleDatatype> key=simpleType could not be resolved
00:15:36 [WRN][            grt]: /Applications/MySQLWorkbench.app/Contents/Resources/data/table_templates.xml:106: link 'com.mysql.rdbms.mysql.datatype.varchar' <object db.SimpleDatatype> key=simpleType could not be resolved
00:15:36 [WRN][            grt]: /Applications/MySQLWorkbench.app/Contents/Resources/data/table_templates.xml:229: link 'com.mysql.rdbms.mysql.datatype.int' <object db.SimpleDatatype> key=simpleType could not be resolved
00:15:36 [WRN][            grt]: /Users/username/Library/Application Support/MySQL/Workbench/connections.xml:27: link 'D69F0816-6CCC-452C-AD14-92F577DF2432' <object GrtObject> key=owner could not be resolved
00:15:36 [INF][      WBContext]: System info:
        MySQL Workbench Community (GPL) for Mac OS X version 6.3.8 CE build 1228 (64 bit)
        Configuration Directory: /Users/username/Library/Application Support/MySQL/Workbench
        Data Directory: /Applications/MySQLWorkbench.app/Contents/Resources
        Cairo Version: 1.10.2
        OS: macOS 10.12.x Sierra
        CPU: 4x Intel(R) Core(TM) i5-4278U CPU @ 2.60GHz - 16.00GiB RAM

00:15:36 [INF][    WQE backend]: Found auto-save workspace /Users/username/Library/Application Support/MySQL/Workbench/sql_workspaces/localhost_23306-1.autosave
00:15:39 [INF][      SqlEditor]: Opened connection 'localhost 23306' to (Debian) version 5.5.53-0+deb8u1
00:15:40 [INF][     AutoCCache]: Initializing autocompletion cache for localhost_23306

How to repeat:
- connect to a server
- open a SQL Editor tab
- write something on the editor
- click the close button of the editor tab
- a dialog appears which asks "save" or "don't save" or "cancel"
- click "don't save"
- the infinite loop begins

*another reproduce method*
- a dialog appears which asks "save" or "don't save" or "cancel"
- click "save"
- specify an existing filename
- the dialog asks "replace" or not. click the replace button
- the infinite loop  begins

*workaround*
save the editor tab before closing, without replacing any existing file.
[2 Jan 16:36] Miguel Solorzano
Thank you for the bug report. Duplicate of http://bugs.mysql.com/bug.php?id=83658.