Bug #84377 Multiple crashes or hangs on OS X Sierra (10.12.2) when trying to close a tab
Submitted: 30 Dec 2016 13:14 Modified: 30 Dec 2016 23:36
Reporter: Johan Persson Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:6.3.8 OS:Mac OS X (10.12.2)
Assigned to:
Tags: GUI crash, OS X Sierra

[30 Dec 2016 13:14] Johan Persson
Description:
This is an almost 100% repeatable crash on OS X. After having a few tabs open in a specific session and then trying to close a tab the GUI 9 times out of 10 crashes. On a few instances it also hangs indefinitely.

Additional information is that I connect to my server over an SSH link but that doesn't seem to be related since the crash seems to be the the frontend Java stuff.

For me this is trivial to repeat. Just open a session, create a few tabs (SQL queris, result tabs etc.) run a few arbitrary queries.

I have included a number of example crashlogs.

How to repeat:
For me this is trivial to repeat. Just open a session over SSH to a server with existing DB, create a few tabs (SQL queries, result tabs etc.) run a few arbitrary queries and then try to close one of the tabs. This will more often result in a complete crash with the crashlog indicating a classic SIGSEGV exception.
[30 Dec 2016 13:16] Johan Persson
Crashlog 1

Attachment: MySQLWorkbench_2016-12-29-234522_psi.crash (application/octet-stream, text), 89.18 KiB.

[30 Dec 2016 13:16] Johan Persson
Crashlog 2

Attachment: MySQLWorkbench_2016-12-29-153839_psi.crash (application/octet-stream, text), 89.13 KiB.

[30 Dec 2016 23:07] Johan Persson
Using 6.3.8.0 give freezes instead crashes more often. See included freeze crash log

Attachment: hung-crashlog.psi.crash (application/octet-stream, text), 1.19 MiB.

[30 Dec 2016 23:36] Miguel Solorzano
Thank you for the bug report. Duplicate of http://bugs.mysql.com/bug.php?id=83658.