Bug #84357 MySQLWorkBench stops responding when using SQL editor. App is unusable.
Submitted: 28 Dec 2016 11:29 Modified: 28 Dec 2016 12:05
Reporter: Kane McConnell Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:6.3.8 build 1228 CE (64 bits) OS:Mac OS X (10.12.2)
Assigned to:
Tags: crash, force quit, not responding, Sierra, sql editor

[28 Dec 2016 11:29] Kane McConnell
Description:
As of yesterday, WorkBench is completely unusable on MacOS 10.12.2 (Sierra). We can open the app, connect to a local MySQL instance, but running any query in the SQL Editor, or even closing the SQL Editor causes the entire app to stop responding requiring a force quit to close the app. The issue does not appear to be with the MySQL server instance as other applications and command line utils work just fine with the same instance.

We use WorkBench to connect to MySQL running within a Vagrant Box on the following environment:

MacOS 10.12.2
VirtualBox 5.1.8 r111374 (Qt5.5.1)
Vagrant 1.8.7

Within Vagrant:
Ubuntu 16.04.1 LTS (GNU/Linux 4.4.0-57-generic x86_64)
MySQL Ver 14.14 Distrib 5.7.16, for Linux (x86_64) using EditLine wrapper

How to repeat:
1. Open MySQLWorkBench.
2. Open a new connection.
3. Run a simple query ("SELECT CURRENT_TIMESTAMP()").

App should quit responding. Force quit.

4. If not attempt to close SQL Editor.

App should quit responding. Force quit.

Have also connected after a force quit, but then unable to close the SQL Editor with a message stating that the SQL IDE is busy. Have also completely removed the app as well as related files from the machines, installed fresh download of the app. Problem is consistent.
[28 Dec 2016 12:05] Miguel Solorzano
Thank you for the bug report. Duplicate of http://bugs.mysql.com/bug.php?id=83658.