Bug #84239 MySQL Workbench frequently hangs when attempting to execute queries
Submitted: 16 Dec 2016 19:01 Modified: 17 Dec 2016 1:21
Reporter: Doug Couvillion Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:6.3.8 OS:Mac OS X
Assigned to:

[16 Dec 2016 19:01] Doug Couvillion
Description:
MySQL Workbench frequently hangs when attempting to execute a query or “use” statement in the query window.  When this happens it is always the first query or command to be executed after opening a connection to the database.  If the first query works the rest seem to work fine too.  This happens frequently enough it almost makes MySQL Workbench unusable.

How to repeat:
1. Open MySQL Workbench.
2. Connect to a database.
3. Run a simple query or even a “use <database>;” command.

When the problem occurs there will be no output in the “Action Output” panel and the spinner in the query tab will spin indefinitely.  At that point the only solution is to use the OS X Force Quit tool to kill MySQL Workbench.
[17 Dec 2016 1:21] Miguel Solorzano
Thank you for the bug report. Duplicate of http://bugs.mysql.com/bug.php?id=83658.
[18 Dec 2016 22:59] Don Kramer
Bug seems to be even more pronounced for me since macOS Sierra Version 10.12.2.