Bug #84203 Application and tabs not closing
Submitted: 14 Dec 2016 9:08 Modified: 14 Dec 2016 9:52
Reporter: Milos Baran Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:6.3.8 OS:Mac OS X (macOS 10.12.x Sierra)
Assigned to:
Tags: WBBugReporter

[14 Dec 2016 9:08] Milos Baran
Description:
Hi,

I have a very strange issue with MySQL Workbench last few versions.
I'm on the latest MacOS distribution and latest MySQLWorkbench version at this moment.

Few updates ago the app started behaving weirdly.
When I launch it and open first connection:
- query is not returning any results. Flash button is disabled but the stop one is not enabled. It's just spinning (Query is fine).
- When I try to close the connection tab I get a message "Cannot close SQL IDE while being busy"
- Unless I crash the app with Force Quit it will not close.

The only workaround I found is to open 2 connections.
The first one is "broken" and the second one is working fine. Without any issues.

But then when trying to close (even if no query is running in the first connection) I'm unable to do so. It will always give me the same message "Cannot close SQL IDE while being busy".

Just small observations.
The close "x" icon on query tabs either does not accept the click or I have to click several times in order to actually close the required tab.
Clicking on "x" on connection tab (the first one) doesn't do anything. Irrelevant how many times I click on it.

The only way to close the app is Force Quit.

----[For better reports, please attach the log file after submitting. You can find it in /Users/milos/Library/Application Support/MySQL/Workbench/log/wb.log]

How to repeat:
Please see description for full details
[14 Dec 2016 9:52] Miguel Solorzano
Thank you for the bug report. Duplicate of http://bugs.mysql.com/bug.php?id=83658.
[18 Dec 2016 22:59] Don Kramer
Bug seems to be even more pronounced for me since macOS Sierra Version 10.12.2.