Bug #84140 MySQL Workbench hangs on any query on the first connection
Submitted: 9 Dec 2016 8:34 Modified: 9 Dec 2016 9:07
Reporter: Leoš Přikryl Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:6.3.8 build 1228 OS:Mac OS X (10.12.1 (16B2657))
Assigned to:
Tags: execute query freeze hangs

[9 Dec 2016 8:34] Leoš Přikryl
Description:
The very first connection I open when I start MySQL Workbench cannot execute any query. It just runs forever. When I open second connection (even to the same database) it works without any problems.

It only happens on MacOS. I verified that it works on Windows 10. There are more people complaining about it at http://stackoverflow.com/questions/39399563/mysql-workbench-6-3-mac-hangs-on-simple-querie...

One suggestion from the above mentioned StackOverflow is to disable SSL for the connection, but it didn't help me. The only workaround that works for me is to ignore the first tab with connection completely, open another one and run my queries there.

How to repeat:
Start MySQL Workbench.
Open any saved connection.
Type in any SQL query.
Try to execute it. It will run forever.

If you open the same connection again in another tab and run the same query, it works.

Suggested fix:
Make it work in the first tab as well.
[9 Dec 2016 9:07] Miguel Solorzano
Thank you for the bug report. Duplicate of http://bugs.mysql.com/bug.php?id=83658.