Bug #84049 MySQL for Excel and comma separator in currency
Submitted: 4 Dec 2016 11:55 Modified: 5 May 2017 19:20
Reporter: Daniel da Veiga Daniel Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL for Windows: MySQL for Excel Severity:S3 (Non-critical)
Version:1.3.6 OS:Microsoft Windows
Assigned to: CPU Architecture:Any

[4 Dec 2016 11:55] Daniel da Veiga Daniel
Description:
When I try to create a table from the spreadsheet, I get errors because currency in my country has a comma separating the value and decimal part. Apparently MySQL for Excel takes the system separator every time, because even converting the data (removing the comma) in the spreasheet, MySQL for Excel still shows it with a comma and the command fails.

How to repeat:
In a computer with Windows 10 (latest updates) and Brazilian Portuguese regional settings, in Office 2010 Home and Studdent, load a spreasheet with values corresponding to currency or any decimal point. Try to convert that spreasheet to a MySQL table and see it fail as number of fields and values are wrong because there is a comma separating the number and decimal parts.

Suggested fix:
Make MySQL for Excel not take the regional settings for this kind of numeric value, as it goes against the standard for decimal values in the database.
[4 Dec 2016 16:15] MySQL Verification Team
Looks like regression: https://bugs.mysql.com/bug.php?id=73293.
[7 Dec 2016 10:10] Chiranjeevi Battula
Hello  Daniel,

Thank you for the bug report .
Verified this behavior on MS Excel 2013 with MySQL for Excel 1.3.6.

Thanks,
Chiranjeevi
[7 Dec 2016 10:10] Chiranjeevi Battula
Screenshot

Attachment: 84049.JPG (image/jpeg, text), 211.50 KiB.

[9 Dec 2016 1:16] Javier TreviƱo
Posted by developer:
 
Reverted back the way Export Data operations prepare data to be exported so the DataTable container has the final data types before the operation takes place, this automatically makes the decimal numbers conversion from any locale to an invariant one.
The locale-free fix for numbers was removed in 1.3.5 where that fix was found to introduce other problems. Now it has been added back and the other problems sorted out.
[5 May 2017 18:51] Rafael Antonio Bedoy Torres
Posted by developer:
 
Fixed on 1.3.7 build 2
[5 May 2017 18:52] Rafael Antonio Bedoy Torres
Posted by developer:
 
Fixed on 1.3.7 build 2
[5 May 2017 19:18] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL for Excel 1.3.7 release, and here's the changelog entry:

Excel worksheets that had currency values with comma separators produced errors when
the data was exported to a MySQL table.

Thank you for the bug report.