Bug #84045 Lock up/no return when executing query with more than 300 rows
Submitted: 3 Dec 2016 16:32 Modified: 4 Dec 2016 14:40
Reporter: Jeremy Roth Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:6.3.8 1228 OS:Mac OS X
Assigned to: CPU Architecture:Any

[3 Dec 2016 16:32] Jeremy Roth
Description:
MySQL Workbench performs as expected against MySQL Server 5.6.  This bug occurs with MySQL version 5.7.16 (running on Ubuntu Linux 16.04). The tool connects (over SSH) fine and can show tables, users, etc. Queries with a limit of fewer than 300 (or so) rows can be executed. However, if the query is larger than 300 or if the limit is not set to 300 then the query spins indefinitely. Halting the query causes MySQL Workbench to fully lock up.

How to repeat:
Connect to a MySQL Server 5.7.1 database. Execute a simple query that will return more than 300 rows.
[4 Dec 2016 14:40] MySQL Verification Team
Thank you for the bug report. Duplicate of http://bugs.mysql.com/bug.php?id=83992 issue when connected using ssh.