Bug #83992 Workbench crashes always when table have text column and more rows are returned
Submitted: 28 Nov 2016 15:35 Modified: 24 May 2018 15:28
Reporter: Valentin Gjorgjioski Email Updates:
Status: QA review Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S1 (Critical)
Version:6.3.8 OS:Microsoft Windows
Assigned to: CPU Architecture:Any
Tags: crash, ssh, text, workbench

[28 Nov 2016 15:35] Valentin Gjorgjioski
Description:
I have two tables that at the moment causing this problem: 

CREATE TABLE `page` (
  `page_key` enum('ABOUT_US','FAQ') NOT NULL,
  `fk_language_id` smallint(5) unsigned NOT NULL,
  `content` longtext NOT NULL,
  `created` datetime NOT NULL DEFAULT CURRENT_TIMESTAMP,
  `updated` timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP ON UPDATE CURRENT_TIMESTAMP,
  PRIMARY KEY (`page_key`,`fk_language_id`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;

when I do query like select * from `page`; - it hangs up, until timeout. On the server side query is finished instantly. This table has 52 rows. 

12K     page.frm
9.1M    page.ibd

How to repeat:
See above. 

Let me know if I can provide additional details. When tables are empty or have very small number of rows - it works.
[28 Nov 2016 16:43] MySQL Verification Team
Please provide the dump file of the table ( insert data ) private if you wish using the Files tab. Thanks.
[2 Dec 2016 15:59] Valentin Gjorgjioski
One more thing to add - this is a connection made through SSH tunnel. I can test later if needed if there is any difference if it is a direct connection. I suspect a bit that this might be a case, since the older version of workbench had lot of issues with ssh tunnels, which 6.3.8 seems to fixed but maybe introduced a new one.
[2 Dec 2016 19:09] MySQL Verification Team
Thank you for the feedback. Application hangs when querying using ssh connection.
[4 Dec 2016 14:41] MySQL Verification Team
http://bugs.mysql.com/bug.php?id=84045 marked as duplicate of this one.
[5 Dec 2016 23:44] MySQL Verification Team
http://bugs.mysql.com/bug.php?id=84063 marked as duplicate of this one.
[7 Feb 2017 14:45] Valentin Gjorgjioski
Having bit different problem on Mac, but it seems related. 

The spinner spins but I get no results. And this happens with almost all tables. It worked just once in 10 tries (always needed to quit with force quit). 

The only time it worked was immediately afterI changed the connection from localhost to 127.0.0.1 - I don't know how this could be related, but now even with 127.0.0.1 it does not work. 

The same workaround from windows (creating a tunnel manually from terminal) and connecting to it works without any problem. 

MySQL Workbench Community (GPL) for Mac OS X version 6.3.8 CE build 1228 (64 bit)
Cairo Version: 1.10.2
OS: macOS 10.12.x Sierra

I will be happy to provide more info and to see this bug solved.
[8 Feb 2017 12:50] Valentin Gjorgjioski
Hi, you should probably ignore my last comment. It seems totally unrelated to this bug. I created a new bug report about it: #84883 https://bugs.mysql.com/bug.php?id=84883
[3 Mar 2018 18:55] MySQL Verification Team
https://bugs.mysql.com/bug.php?id=89866 marked as duplicate of this one.