Bug #83956 MySQL workbench hangs on any query in the first tab.
Submitted: 24 Nov 2016 15:33 Modified: 24 Nov 2016 15:47
Reporter: Denis Putnam Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Workbench Severity:S2 (Serious)
Version:6.3.x OS:Mac OS X (macOS Sierra Version 10.12.1)
Assigned to:
Tags: Connection, hangs

[24 Nov 2016 15:33] Denis Putnam
Description:
MySQL workbench hangs when you make the first connection and try to query any table in the first tab.  Openning a second connection allows queries in the second tab to work even though the first tab has hung queries.

How to repeat:
Bring up MySQL workbench and click on the local connection.  The first tab will open up.  Open up a schema.  Open the “Tables”.  Click on the icon with the lightening bolt.  This will open a query tab and a query is supposed to execute to show the contents of the table.  This query will hang.

The workaround is to never perform a query in the first connection, but to open a second connection/tab.  The queries will run there.

Version of MySQL was installed from mysql-5.7.16-osx10.11-x86_64.dmg.

Suggested fix:
No suggestions.
[24 Nov 2016 15:47] Miguel Solorzano
Thank you for the bug report. Duplicate of http://bugs.mysql.com/bug.php?id=83658.
[18 Dec 2016 22:57] Don Kramer
Bug seems to be even more pronounced for me since macOS Sierra Version 10.12.2.