Bug #83815 timstamp is wrong
Submitted: 15 Nov 2016 2:09 Modified: 15 Nov 2016 5:42
Reporter: Jack chen Jack Email Updates:
Status: Duplicate Impact on me:
None 
Category:Connector / J Severity:S1 (Critical)
Version:6.0.3 OS:CentOS
Assigned to: CPU Architecture:Any
Tags: china, CST, mysql-connector-java, timestamp

[15 Nov 2016 2:09] Jack chen Jack
Description:
in my project ,when insert data to a table,the timestamp field was not the same as mysql-server or local-time.
Just like that:the right time is :2016-11-15 09:47:35,but after insert or update the timestamp field ,i get 2016-11-14 19:49:26.

I had check date and time_zone in centos server ,mysql server and java client ,everything is ok.

How to repeat:
use mysql-connector-java:6.0.3

Suggested fix:
use mysql-connector-java:5.1.40
[15 Nov 2016 5:42] Chiranjeevi Battula
Hello  Jack chen Jack,

Thank you for the bug report.
This is most likely duplicate of Bug #82192, please see Bug #82192.

Thanks,
Chiranjeevi.