Bug #83754 Visual studio connector not working .NET
Submitted: 9 Nov 2016 13:19 Modified: 10 Nov 2016 9:58
Reporter: Thauriq Jappie Email Updates:
Status: Verified Impact on me:
None 
Category:Connector / NET Severity:S1 (Critical)
Version:6.9.9 /6.8.0 OS:Microsoft Windows (windows 10)
Assigned to: CPU Architecture:Any
Tags: MySQL, Visual Studio

[9 Nov 2016 13:19] Thauriq Jappie
Description:
when using the datasource configuration wizard, in visual studio 2013, to add a data source, i get an error that says:

"some updating commands could not be generated automatically.the database returned the following error: 
You have a usable connection already."

there after another error saying it could not retrieve schema.

How to repeat:
download visual studio 2013/2015

download MYSQL 1.4-2.0.4 ----full package install
- tried both /net connectors 6.8.0 and 6.9.9 and the latest 7.0.5

open visual studio

create new project

connect to MYSQL DB in "Tools" -> "connect to database" -> fill details

create Data source -> select the connection string-> select the table.

error should appear now

Suggested fix:
no idea? i tried all i could think of. but seems like MYSQL side.
[9 Nov 2016 13:27] Thauriq Jappie
Error

Attachment: Capture4.PNG (image/png, text), 20.96 KiB.

[9 Nov 2016 13:27] Thauriq Jappie
after error

Attachment: Capture5.PNG (image/png, text), 18.69 KiB.

[9 Nov 2016 14:42] Chiranjeevi Battula
Hello  Thauriq Jappie,

Thank you for the bug report.
Verified this behavior on Visual Studio 2013 (C#.Net) and Connector/NET 6.9.9 version.

Thanks,
Chiranjeevi.
[9 Nov 2016 14:42] Chiranjeevi Battula
Screenshot

Attachment: 83754.JPG (image/jpeg, text), 65.79 KiB.

[9 Nov 2016 14:43] Chiranjeevi Battula
Screenshot

Attachment: 83754_1.JPG (image/jpeg, text), 62.65 KiB.

[10 Nov 2016 6:38] Thauriq Jappie
Thank you for the swift response. 
my apologies for being in the dark on these queries but is their a solution or work around? or will it just be updated on here?
[10 Nov 2016 7:05] Thauriq Jappie
I have tried various other connectors, much older and the latest in dev. 
none seem to be working.
could the issue be somewhere else?
[10 Nov 2016 8:58] Thauriq Jappie
i created a test environment with visual studio 2012 and MYSQL workbench 5.2 CE.
all i did here was upgrade the connector/net to 6.6.8.

that seems to work. 

this is not my solution as i am working on later versions of both products. i thought this may help in some way.
[10 Nov 2016 9:58] Thauriq Jappie
update. i tested this environment on visual studio 2013, and it seems to work.
i also added the updated connector and MYSQL for visual studio 2.0.4 seperately.

is in not maybe the new installer, the server or workbench?
[21 Mar 2018 10:55] Filippo Berardo
I'm using VS 2017 and this bug is on all version of CONNECTOR .NET from 6.9.9 to 8.x.x and in dev connectors.

If have an existing project connected with mysql and when i add a table in my database and i want to refrsh tables with the wizard of VS, the table is found but when it tries to connect happens this message " you have a usable connection already". 
I tried changing either MYSQL FOR VISUAL STUDIO but no way, even with 2.0.x in dev.

This is frustrating because we cannot use either ENTITY FRAMEWORK that is not working too!
[13 Apr 2018 17:43] Bob Stammers
New VS2017 install, new MySQL install, Windows 10 Home
New project, new bindingsource, same error

Tried multiple combinations of MySQL for Visual Studio, .NET connector & ODBC connectors, all various versions, same error
[27 Oct 2018 19:09] Görög Márton
Guys its a critical issue for years now. Visual Studio is the most used IDE, and for years this issue cant be solved? Who are you targeting? Its a shitty solution to try to install in good order archive version of software packages, but some of the suggested packages doesn't even seem to work with VS 2017. So how to use MySQL?
[27 Oct 2018 19:11] Görög Márton
A Critical bug for two years, and has not even been assigned to anybody.
[5 Nov 2018 17:12] Benjamin Gilbert
Can attest to this being an issue for me too. Combine it with the no 'caching_sha2_password' method error and I'm truly mind blown that these connectors were released
[25 Jul 2019 7:02] Toni Macías
Same behavior with Visual Studio 2017/2015 and Mysql Net connector 6.9.8/6.9.9