Bug #83611 EER Diagram doesn't show Japanese characters
Submitted: 30 Oct 2016 3:15 Modified: 10 Jan 2017 12:24
Reporter: Ken Suzuki Email Updates:
Status: Verified Impact on me:
None 
Category:MySQL Workbench: Modeling Severity:S2 (Serious)
Version:6.3.8 OS:Mac OS X (10.12)
Assigned to: CPU Architecture:Any
Tags: character, EER Diagram, japanese

[30 Oct 2016 3:15] Ken Suzuki
Description:
In Preference > Modeling > Appearance panel, I set "Configure Fonts For: Japanese".

In EER Diagram editor, selecting one of tables, putting Japanese to one of column's name, Japanese character shows in the diagram. This is fine.

But after saving the diagram to a file, then open it with MySQL Workbench, the Japanese character is corrupted in the diagram.

This is occurred in MacOS X 10.12.
I checked MacOS X 10.11 and MySQL Workbench 6.3.8 doesn't have this problem.

Note: This problem is not in table's name but in column's name. Table name shows Japanese after reopening.

How to repeat:
In Preference > Modeling > Appearance panel, I set "Configure Fonts For: Japanese".

In EER Diagram editor, select one of tables, put Japanese to one of the column's field.

Saved the diagram to a file, then open it again, check the table in the diagram.

Suggested fix:
Show Japanese in EER diagram after reopening from a file.
[30 Oct 2016 6:57] Ken Suzuki
This problem occurs when Model > Object Notation > IDEF1X is selected.

I have to correct that Mac OS X 10.11 has this problem too.
[10 Jan 2017 12:24] MySQL Verification Team
Thank you for the report.
Observed this on OS X 10.11.x El Capitan with WB 6.3.8 and when Model > Object Notation > IDEF1X/Classic is selected.