Bug #8345 bad startup - not responding
Submitted: 6 Feb 2005 20:51 Modified: 6 Feb 2005 21:57
Reporter: Maarten Abbink Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server Severity:S1 (Critical)
Version:3.x to 4.1.8 OS:Microsoft Windows (Windows)
Assigned to: CPU Architecture:Any

[6 Feb 2005 20:51] Maarten Abbink
Description:
My problem is that my mysql server dosn't respond in any way. I tried to fix the problem with a restart and several updates.
I use the server for testing and upgrading my homepage. It is started manually every time and always shut down together with the  OS. After one of these shutdowns I could start the server without any problems but it didn't respond from then on. PHPmyAdmin shows the following message "#2003 - The server is not responding", like any other client does.
I also tried to shut it down manually by using the "shut down tool", but that didn't lead to anything. It just quit with a beep and not having done anything.
I even tried it with all security (firewalls) off.
Because of the fact that nothing has been installed, removed or added to the system, I cannot see a reason for this error.

How to repeat:
As described above, mysql didn't respond after shutting it down by shutting down the OS. (Actually that is not the official way, but it didn't cause any troubles up to now.)

Suggested fix:
I tried to restart the server manually but the bug kept alive and no resart led to anything.
It seems that something in the OS that has changed without noticing me causes the problems. I don't know what or where to look for it.

PS: I'm sorry for using bad english, but my english knowledge is not the best one.
[6 Feb 2005 21:57] Miguel Solorzano
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.mysql.com/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to 'Open'.

Thank you for your interest in MySQL.
[9 Feb 2005 19:18] Maarten Abbink
Update:
OS: Windows XP professions service pack 2
This bug appeared after installing Mediaplayer 10. Neither uninstalling the mediaplayer helped, nor a "system restore".
I removed all files from xampp, especially those from mysql. I also removed all entries with "mysql" from the registry (regedit): no success.
[10 Feb 2005 20:01] Maarten Abbink
C:\xampp\mysql\data\mypc.err tells me:
mysql\bin\mysqld.exe: ready for connections.
Version: '4.1.8'  socket: ''  port: 3306  Source distribution