Bug #8342 Query browser cannot execute it's own generated SQL
Submitted: 6 Feb 2005 11:47 Modified: 6 Feb 2005 13:54
Reporter: Matt Mower Email Updates:
Status: Duplicate Impact on me:
None 
Category:MySQL Query Browser Severity:S2 (Serious)
Version:1.1.5 OS:Microsoft Windows (WinXP)
Assigned to: CPU Architecture:Any

[6 Feb 2005 11:47] Matt Mower
Description:
I'm attempting to modify a table generated using QueryBrowser however, in trying to do so, I seem to have found that it cannot consume it's own SQL.

When I try to execute SQL generated by selecting "Copy SQL to clipboard" from a table definition I get:

Error: 1064
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ';
CREATE TABLE `xtab` (
  `id` int(10) unsigned NOT NULL auto_increment,
  `' at line 1

How to repeat:
Open a schemata
Select a table
Right click & select 'Copy SQL to Clipboard'
Select SQL Query Area
Paste SQL
Execute
[6 Feb 2005 12:03] Matt Mower
Looks like my bug is a duplicate of #7609.  Same symptoms.

I've also noticed how sometimes, if I remove the 'DROP TABLE' part of the generated SQL (and drop the table manually) then I can run the 'CREATE TABLE' part although I do still see an error in the status bar:

Access violation at address 00568F76 in module 'MySQLQueryBrowser.exe'. Read of address 0000002C
[6 Feb 2005 13:54] Victoria Reznichenko
Duplicate for #7609