Bug #83395 Every line a error, even though it isn't.
Submitted: 16 Oct 2016 3:40 Modified: 9 Feb 2018 22:47
Reporter: Nicholas Leonard Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Workbench: SQL Editor Severity:S3 (Non-critical)
Version:6.3.7 OS:Microsoft Windows (Windows 10 - Education)
Assigned to: CPU Architecture:Any
Tags: editor

[16 Oct 2016 3:40] Nicholas Leonard
Description:
If you write code that starts off as an error, then fix it, it will say it's an error.

How to repeat:
Write

CREATE TABLE
(
);

Then fill in the variable.

Suggested fix:
Close editor, then open it again.
[16 Oct 2016 14:00] Miguel Solorzano
Please attach in tab Files a screen-shot when: it will say it's an error. Thanks.
[16 Oct 2016 17:06] Nicholas Leonard
Snapshot of error.

Attachment: Capture.JPG (image/jpeg, text), 24.85 KiB.

[17 Oct 2016 6:32] Umesh Shastry
Thank you for the screenshot, observed this at my end.
[17 Oct 2016 6:33] Umesh Shastry
Also, related - Bug #82147
[18 Oct 2016 9:25] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=83415 marked as duplicate of this one.
[25 Oct 2016 23:23] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=83536 marked as duplicate of this one.
[7 Nov 2016 22:15] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=83729 marked as duplicate of this one.
[9 Nov 2016 16:31] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=83756 marked as duplicate of this one.
[24 Dec 2016 20:05] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84330 marked as duplicate of this one.
[4 Jan 2017 23:49] Miguel Solorzano
http://bugs.mysql.com/bug.php?id=84412 marked as duplicate of this one.
[9 Feb 2018 22:45] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.0 release, and here's the changelog entry:

The invalid syntax indicator that appears on each line of the SQL Editor
did not change after the syntax was corrected or completed. This fix
ensures that the editor re-evaluates each change.

Thank you for the bug report.
[9 Feb 2018 22:45] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.0 release, and here's the changelog entry:

The invalid syntax indicator that appears on each line of the SQL Editor
did not change after the syntax was corrected or completed. This fix
ensures that the editor re-evaluates each change.

Thank you for the bug report.
[9 Feb 2018 22:46] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.0 release, and here's the changelog entry:

The invalid syntax indicator that appears on each line of the SQL Editor
did not change after the syntax was corrected or completed. This fix
ensures that the editor re-evaluates each change.

Thank you for the bug report.
[9 Feb 2018 22:47] Christine Cole
Fixed as of the upcoming MySQL Workbench 8.0.0 release, and here's the changelog entry:

The invalid syntax indicator that appears on each line of the SQL Editor
did not change after the syntax was corrected or completed. This fix
ensures that the editor re-evaluates each change.

Thank you for the bug report.
[21 Mar 2018 16:56] Christine Cole
Posted by developer:
 
Fixed as of the upcoming MySQL Workbench 8.0.11 release, and here's the changelog entry:

The invalid syntax indicator that appears on each line of the SQL Editor
did not change after the syntax was corrected or completed. This fix
ensures that the editor re-evaluates each change.

Thank you for the bug report.