Bug #8322 AC_PROG_LIBTOOL problem with autoconf, preserve-dup-deps problem
Submitted: 4 Feb 2005 17:37 Modified: 15 Feb 2005 21:05
Reporter: Mikael Ronström Email Updates:
Status: Closed Impact on me:
None 
Category:MySQL Server: Compiling Severity:S1 (Critical)
Version:5.0-bk (2005-02-04) OS:Mac OS X (Mac OS X 10.3)
Assigned to: Petr Chardin CPU Architecture:Any

[4 Feb 2005 17:37] Mikael Ronström
Description:
Run as an example
./configure --with-ndb-cluster --with-debug (problem comes with more or less any parameters

cat build_osx 
aclocal; autoheader; autoconf; automake
(cd innobase; aclocal; autoheader; autoconf; automake)
(cd bdb/dist; sh s_all)
C=gcc CFLAGS="-O3 -fno-omit-frame-pointer" CXX=gcc \
CXXFLAGS="-O3 -fno-omit-frame-pointer -fno-common -felide-constructors \
-fno-exceptions -fno-rtti" ./configure \
--with-extra-charsets=complex --enable-thread-safe-client \
--with-debug --with-ndb-test --with-ndb-shm \
--without-berkeley-db --without-innodb --without-openssl \
--prefix=/usr/local/mysql --with-ndbcluster

c-a109e253 [~] % cd wl2405
/Users/mikron/wl2405
c-a109e253 [~/wl2405] % ../build_osx 
configure.in:239: error: possibly undefined macro: AC_PROG_LIBTOOL
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.

Later on if continuing the build process the error message below is received:
./configure: line 5087: AC_PROG_LIBTOOL: command not found

and later
preserve-dup-deps --mode=link gcc  -g -O -DDBUG_ON -DSAFE_MUTEX -fno-omit-frame-pointer   -DHAVE_DARWIN_THREADS -D_P1003_1B_VISIBLE -DSIGNAL_WITH_VIO_CLOSE -DSIGNALS_DONT_BREAK_READ -DIGNORE_SIGHUP_SIGQUIT   -o factorial  my_main.o factorial.o libdbug.a ../mysys/libmysys.a ../strings/libmystrings.a -lm  
make[2]: preserve-dup-deps: Command not found
make[2]: [factorial] Error 127 (ignored)
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include    -g -O -DDBUG_ON -DSAFE_MUTEX -fno-omit-frame-pointer   -DHAVE_DARWIN_THREADS -D_P1003_1B_VISIBLE -DSIGNAL_WITH_VIO_CLOSE -DSIGNALS_DONT_BREAK_READ -DIGNORE_SIGHUP_SIGQUIT -MT dbug_analyze.o -MD -MP -MF ".deps/dbug_analyze.Tpo" -c -o dbug_analyze.o dbug_analyze.c; \
then mv -f ".deps/dbug_analyze.Tpo" ".deps/dbug_analyze.Po"; else rm -f ".deps/dbug_analyze.Tpo"; exit 1; fi
preserve-dup-deps --mode=link gcc  -g -O -DDBUG_ON -DSAFE_MUTEX -fno-omit-frame-pointer   -DHAVE_DARWIN_THREADS -D_P1003_1B_VISIBLE -DSIGNAL_WITH_VIO_CLOSE -DSIGNALS_DONT_BREAK_READ -DIGNORE_SIGHUP_SIGQUIT   -o dbug_analyze  dbug_analyze.o libdbug.a ../mysys/libmysys.a ../strings/libmystrings.a -lm  
make[2]: preserve-dup-deps: Command not found
make[2]: [dbug_analyze] Error 127 (ignored)

How to repeat:
Run configure on above
Versions of tools used

autoconf 2.59
automake 1.9.4
libtool: not known but have successfully built MySQL for 15 months

Suggested fix:
Don't know
[15 Feb 2005 20:07] Petr Chardin
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.mysql.com/documentation/ and the instructions on
how to report a bug at http://bugs.mysql.com/how-to-report.php

Additional info:

Not a bug. These were some local libtool problems at mikael's host. They were resolved.
[15 Feb 2005 21:05] Petr Chardin
Some more info, which might help someone experiencing alike problems:
one must use the latest libtool version on Mac OS X (1.5.14 seems to work).