Bug #83179 Numeric numbers rounded at csv export
Submitted: 28 Sep 2016 6:19 Modified: 29 Sep 2016 23:12
Reporter: Vladimir Kochan Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Workbench Severity:S1 (Critical)
Version:6.3.6 OS:Linux (Ubuntu 16.04.1 LTS)
Assigned to: CPU Architecture:Any
Tags: WBBugReporter

[28 Sep 2016 6:19] Vladimir Kochan
Description:
Exported numeric numbers are rounded in exported csv file

How to repeat:
1. connect to any database
2. select any table with NUMERIC type; NUMERIC (8,2) in my case
3. Right click on table name
4. from context menu select "Table Data Export Wizard"
5. let selected all fields and "next"
6. enter any file path
7. use "csv" export, Line separator LF, enclose symbol ", field separator ; let checked "export to local machine"
8. click to next twice
9. look at the generated file, numeric numbers are rounded.
[29 Sep 2016 1:53] Miguel Solorzano
Thank you for the bug report. I couldn't repeat with 6.3.7 on Centos & please try it. If you still get the same issue with 6.3.7 please provide the create table and insert data statement to try your own test case. Thanks.
[29 Sep 2016 10:38] Vladimir Kochan
i can not use 6.3.7 version because i have to use older version from ubuntu repos.
i can test it when ubuntu will update it.

my test:

create table query:

CREATE TABLE `numtest` (
	`id` INT NOT NULL,
	`num` DECIMAL(10,2) NOT NULL,
	PRIMARY KEY (`id`)
)
COLLATE='utf8_slovak_ci'
ENGINE=InnoDB
; 

insert line query:

INSERT INTO `test`.`numtest` (`id`, `num`) VALUES (1, 0.4);

CSV file:
"id";"num"
1;0.0
[29 Sep 2016 23:07] Miguel Solorzano
Test on CentOS 7 with 6.3.7

Attachment: bug83179.png (image/png, text), 258.11 KiB.

[29 Sep 2016 23:12] Miguel Solorzano
Thank you for the feedback. You could see in the prior screenshot attached, it worked as expected with 6.3.7.