Bug #83135 pressing backspace shifts the character in row by 7th place
Submitted: 24 Sep 2016 0:26 Modified: 16 Nov 2016 9:18
Reporter: Rocky Sharma Email Updates:
Status: Can't repeat Impact on me:
None 
Category:MySQL Server: Command-line Clients Severity:S3 (Non-critical)
Version:5.7.15-0ubuntu0.16.04.1 OS:Ubuntu (16.04)
Assigned to: CPU Architecture:Any
Tags: backspace key, mysql command line, MYSQL SERVER

[24 Sep 2016 0:26] Rocky Sharma
Description:
Whenever i press backspace to delete any character. My query text is all shifted by 7 character and last 7 character is gone.

Here is image :- http://i.imgur.com/L5Vmp7e.png

If you see mysql> mysql> ....

that happens when i press backspace.

mysql > create table foo (id int not nulk<press backspace>

and you will get :-

mysql> mysql> create table food (id int no

Unluckily, this doesn't happen every time. it happens some time, but is terribly annoying.

How to repeat:
1 simple way to repeat

mysql > create table foo (id int not nulk<press backspace>

and you will get :-

mysql> mysql> create table food (id int no
[16 Nov 2016 9:18] Umesh Shastry
Hi Rocky Sharma,

Thank you for the report, I'm not seeing this issue at my end.
I couldn't reproduce but this could be happening due to some key binding through .inputrc/.editrc etc. If you can provide more information, feel free to add it to this bug and change the status back to 'Open'.

Thank you for your interest in MySQL.

Thanks,
Umesh